Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera starts with delay and opens up links from Outlook with a delay

  • Dear people,

    I do have the following problem:

    I am using Opera GX with the version: LVL 2 (core: 73.0.3856.396).

    Since a few days ago Opera GX is opening up very slowly when I have started Windows.
    It also opens up links from e.g. emails out of Outlook or any other email program very slowly and with a delay.

    When Opera GX is opening up only a black box with a red lining is showing up. No sign Logo is loading.
    Then this box disappears it takes a few seconds and the browser opens up.
    When the browser is open it is working fine, except for the fact that is opening up links with a delay from other programs like Outlook, Word etc.
    So some thing is slowing this task down.

    When I am opening up Google Chrome the same thing is happening.
    I am using Norton 360 as my anti-virus program. Maybe something is blocked there?

    This is what I have done so far:

    I updated Windows 10 and all drivers of my computer to the latest version.
    I cleaned the cache of Opera and all other browsers (Google Chrome) on my computer.
    I uninstalled all extensions from Opera GX. Except for the Opera Ad-blocker which I cannot uninstall.
    The VPN from Opera is deactivated.
    I uninstalled NordVPN which I am usually using as my VPN.
    Hardware acceleration is disabled.
    Opera GX is my standard browser.

    Before I am uninstalling and reinstalling the browser I thought I report this.
    Maybe some one has stumped on the same problem and has a workaround.
    I am enjoying this browser so far but with the described problems it really is a pain in the ass to work with.

    Best wishes,
    Geniusjayjay

  • @geniusjayjay It seems like the program "Nahimic services" is responsable for these problems. I disabled it and now it seems to work again. But I will check it again after I restart my computer.