Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • I use Adobe Acrobat 9 Pro and have no reason to upgrade it.
    I have a slow computer, so I only upgrade software when I need to, to save money and avoid bloat.

    Opera 23 rips along. But every time I need to link to a pdf file I get the cross icon and a message saying "Adobe reader is out of date". That's fine, I know that, thats how I want it. I just want to open the PDF file in separate window like firefox currently does and what opera 12 (my main browser) used to do.

    But there's no way to bypass the message.

    How can I bypass the message and use an old plugin?

    Is there another work around where the PDF file will open in a separate native Acrobat window?

    Adobe reader plugin is version

  • You could install Adobe Reader XI (, or the PDF.js extension, or another reader to use in Opera. A native PDF reader is coming in future versions too (PDFium).

    You can check the plug-ins you have installed and enabled by typing opera:plugins in the address field and pressing Enter.

    Oh, there's a command line switch to allow outdated plug-ins "--allow-outdated-plugins" adding that to the Opera launcher shortcut may work (personally I never tried that).

  • I've been getting this since at least v22 - and maybe earlier.

    Google will show that other browsers have been getting the message since at least 2011. Chrome seems to be the worst offender, but it's always just a handful of people who se the message and others cannot replicate it.

    The important thing is that updating your Reader won't make the message go away.

    Rafael: The "--allow-outdated-plugins" switch bypasses the error message, but still Opera doesn't show the PDF - just a blank page.

    Opera 12 works just fine with the same plugin as is being used in v24

    Here's a workaround: right-click the PDF link and choose "Save linked content as" and save the document somewhere. As it is being saved, the pop-up download dialog shows at the top-right of the screen. Once the file has downloaded, double-click the dialog (promptly - i.e. before it auto-closes) and the PDF will open in your designated Reader.

  • Unfortunately, you cannot do the right click "Save linked content as" for many links because they link to an intermediate html page that loads the pdf. "Save linked content as" tries to save the intermediate page .htm file.

    Which launcher shortcut do I try the "--allow-outdated-plugins" in? I launch from a start bar pin.
    I guess I could try out a separate shortcut, but thats not a permanent solution.

    I'm not going to install Reader XI. There'sno point. I already have acrobat 9, which has extra editing functions I use regularly. Thats the whole point of this post.\

    I'll try out the PDF.js extention, if I can find it. What is it, just a script that launches Acrobat? That would fix my problem.

    I still think that Opera should give you the option to use any plugin you want. A warning is nice, but I don't want to be forced to use any particular plugin if there is no technical reason to do so

  • Sweet. Found the PDF.js. It opens the PDF using the HTML5 engine used in firefox. That will help me, but a simple script that saves the file somehwere and launces a seperate session of Acrobat would be more usefull for me.

    Does that exist anywhere?

  • Well, there's a possible fix, just disable the Chrome PDF Viewer under opera:plugins. Platform Win8.1 x64, Opera Beta 26.0.1656.20, Acrobat Reader Pro

  • Errata! Disable the Adobe Reader And keep the default Chrome PDF Viewer enabled, that should allow you to download the PDF for further processing.

  • Yeah. Thats what I do with PDF.js. Let it load in there and if I need to open it up in Acrobat.

  • Still, Its gonna suck if I bump into another usable but 'out of date' plugin i need to use.

  • I got the same problem not long ago? and I immediately tried updating my Adobe Reader to the latest version. Alas, it didnt help. Similar problem with Avast antivirus discovered that it wanted 11.0.09 version on Windows XP SP3, while the 11.0.08 is the latest one for this OS. The 11.0.09 is the latest one for Windows 7 or 8. Is Opera's problem of the same kind?

  • i disabled the adobe reader plugin and enabled the chrome pdf viewer
    that worked 😕

  • I also highly dislike seeing the PDF in the browser. I was able to disable it in the PDF reader (Foxit reader as well as Adobe PDF reader) and now Opera forces me to use an internal PDF viewer... AAAAAAAAAAAAAAAAAAAHHHHHHHHHHHHHHRRRRRRRGGGGGGHHHHHHH!!!!!!!!
    OK, disabling the internal PDF viewer works, but for some reason, sometimes Adobe still tries to "steal" the setting and displays PDF in the browser... (even so there is no tick in Adobe setting to display in browser...)
    I wish there was an easy way (like it was in Opera 12) to simply say what file extension I want to open with which application to give me back the control I want.
    I am also not a fan of updating all applications all the time.
    I got an antivirus software and I normally do not go to "insecure" sites. So why should I bother with updating an application that works for me? With new versions just come new bugs that you are needing to find new solutions (AGAIN) for. I rather live with the old bugs and know how to deal with them 🙂

  • I had this same issue, and finally found a resolution.

    download this pdf viewer from opera, and without restarting opera, the pdfs started loading.

    not sure about print issues b/c i haven't tried that.

  • I have the same issue. Is there any way to simply bypass this error and force Adobe Plugin to work? On another machine I have enabled the Chrome/Opera PDF Viewer and this has one big side effect that when I download PDF file from a site and click on the downloads to open it instead of opening in Adobe Acrobat it opens inside Opera in the PDF viewer.

  • I have the same problem in Windows 7 with Opera. I just installed Adobe Reader and the plugin of it does not work.

  • I have the same problem in Windows 7 with Opera. I just installed Adobe Reader and the plugin of it does not work.

    I just found out all I need to do was update Adobe Reader.