Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • This is the linux system information about my installation:

    System:    Host: elisa-K54C Kernel: 5.4.0-54-generic x86_64 bits: 64 Desktop: MATE 1.22.2 Distro: Linux Mint 19.3 Tricia 
    Machine:   Type: Laptop System: ASUSTeK product: K54C v: 1.0 serial: <root required> 
               Mobo: ASUSTeK model: K54C v: 1.0 serial: <root required> UEFI: American Megatrends v: K54C.207 date: 04/18/2012 
    Battery:   ID-1: BAT0 charge: 42.5 Wh condition: 44.6/48.4 Wh (92%) 
    CPU:       Topology: Dual Core model: Intel Core i3-2310M bits: 64 type: MT MCP L2 cache: 3072 KiB 
               Speed: 798 MHz min/max: 800/2100 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 4: 798 
    Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics driver: i915 v: kernel 
               Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa resolution: 1366x768~60Hz, 1366x768~60Hz 
               OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) v: 3.3 Mesa 20.0.8 
    Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel 
               Sound Server: ALSA v: k5.4.0-54-generic 
    Network:   Device-1: Ralink RT5390 Wireless 802.11n 1T/1R PCIe driver: rt2800pci 
               IF: wlp2s0 state: up mac: 84:4b:f5:12:54:06 
               Device-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet driver: atl1c 
               IF: enp4s0 state: down mac: 30:85:a9:11:9f:4d 
               IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
    Drives:    Local Storage: total: 931.52 GiB used: 674.09 GiB (72.4%) 
               ID-1: /dev/sda vendor: Toshiba model: MQ01ABD050 size: 465.76 GiB 
               ID-2: /dev/sdb type: USB vendor: Toshiba model: External USB 3.0 size: 465.76 GiB 
    Partition: ID-1: / size: 176.59 GiB used: 72.16 GiB (40.9%) fs: ext4 dev: /dev/sda7 
               ID-2: swap-1 size: 5.60 GiB used: 370.9 MiB (6.5%) fs: swap dev: /dev/sda6 
    Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A 
               Fan Speeds (RPM): cpu: 2100 
    Info:      Processes: 213 Uptime: 1d 7h 07m Memory: 3.75 GiB used: 1.85 GiB (49.4%) Shell: bash inxi: 3.0.32 
    

    I installed Opera with the official .DEB file.
    When I activate the VPN from the system dock icon I am able to surf the internet with Firefox but I cannot with Opera.
    The error is ERR_CONNECTION_REFUSED.
    When the VPN is off I can surf the internet with both of them.
    Firefox is configured to automatically detect proxy settings but in Opera I can't find a similar setting.
    Tips?

  • Opera version: 72.0.3815.378

  • man chromium

    --proxy-server=host:port
    
    Specify the HTTP/SOCKS4/SOCKS5 proxy server to use for requests.  This overrides any environment variables or settings picked via the  options dialog. An  individual  proxy server is specified using the format:
    
    [<proxy-scheme>://]<proxy-host>[:<proxy-port>]
    
    Where <proxy-scheme> is the protocol of the proxy server, and is one of:
    
    "http", "socks", "socks4", "socks5".
    
    If  the  <proxy-scheme>  is  omitted,  it  defaults to "http". Also note that "socks" is equivalent to "socks5".
    
    Examples:
    
    --proxy-server="foopy:99"
    
    Use the HTTP proxy "foopy:99" to load all URLs.
    
    --proxy-server="socks://foobar:1080"
    
    Use the SOCKS v5 proxy "foobar:1080" to load all URLs.
    
    --proxy-server="socks4://foobar:1080"
    
    Use the SOCKS v4 proxy "foobar:1080" to load all URLs.
    
    --proxy-server="socks5://foobar:66"
    
    Use the SOCKS v5 proxy "foobar:66" to load all URLs.
    
    It is also possible to specify a separate proxy server for different URL types, by  prefixing the proxy server specifier with a URL specifier:
    
    Example:
    
    --proxy-server="https=proxy1:80;http=socks4://baz:1080"
    
    Load https://* URLs using the HTTP proxy "proxy1:80". And load http://*URLs using the SOCKS v4 proxy "baz:1080".
    
    --no-proxy-server
    
    Disables  the  proxy server.  Overrides any environment variables or settings picked via the options dialog.
    
    --proxy-auto-detect
    
    Autodetect proxy configuration. Overrides any environment variables or settings picked via the options dialog.
    
    --proxy-pac-url=URL
    
    Specify proxy autoconfiguration URL. Overrides any environment variables or settings picked via the options dialog.
    
    ENVIRONMENT
    
    Chromium obeys the following environment variables:
    
    all_proxy
    
    Shorthand for specifying all of http_proxy, https_proxy, ftp_proxy
    
    http_proxy, https_proxy, ftp_proxy
    
    The proxy servers used for HTTP, HTTPS, and FTP.  Note: because Gnome/KDE proxy settings may propagate into these variables in some terminals, this variable is ignored (in preference  for actual system proxy settings) when running under Gnome or KDE.  Use the command-line flags to set these when you want to force their values.
    
    auto_proxy
    
    Specify proxy autoconfiguration.  Defined and empty autodetects; otherwise, it should be an autoconfig URL.  But see above note about Gnome/KDE.
    
    SOCKS_SERVER
    
    SOCKS proxy server (defaults to SOCKS v4, also set SOCKS_VERSION=5 to use SOCKS v5).
    
    no_proxy
    
    Comma separated list of hosts or patterns to bypass proxying.
    
  • @fonm I do not understand. I have activated the VPN at the operating system level. With Firefox I can navigate safely. In Opera do I have to manually set the proxy to be able to navigate? It seems absurd to me. In any case which proxy should I enter?

  • @fonm After some tests I found the solution.

    opera --proxy-auto-detect
    

    Thanks a lot!