Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Cannot install upgrade to Opera 69 and new releases

  • My opera is not being upgraded from Opera 68 and it is stuck on version 68.0.3618.173
    When doing sudo apt install ./opera-stable_69.0.3686.77_amd64.deb following error occurs,

    ➜  Downloads sudo apt install ./opera-stable_69.0.3686.77_amd64.deb 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Note, selecting 'opera-stable' instead of './opera-stable_69.0.3686.77_amd64.deb'
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     opera-stable : Depends: libgtk-3-0 (>= 3.19.12) but 3.18.9-1ubuntu3.3 is to be installed
    E: Unable to correct problems, you have held broken packages.
    ➜  Downloads 
    ➜  ~ uname -a
    Linux abc-pc 4.15.0-118-generic #119~16.04.1-Ubuntu SMP Tue Sep 8 14:54:40 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
    ➜  ~ lsb_release -a
    No LSB modules are available.
    Distributor ID:	Ubuntu
    Description:	Ubuntu 16.04.7 LTS
    Release:	16.04
    Codename:	xenial
    

    Same error occurs when doing for 70 or other newer versions. sudo dpkg -i gives same type of error.

    ➜  Downloads sudo dpkg -i ./opera-stable_71.0.3770.171_amd64.deb                                                                          
    (Reading database ... 265992 files and directories currently installed.)
    Preparing to unpack .../opera-stable_71.0.3770.171_amd64.deb ...
    Unpacking opera-stable (71.0.3770.171) over (68.0.3618.173) ...
    dpkg: dependency problems prevent configuration of opera-stable:
     opera-stable depends on libgtk-3-0 (>= 3.19.12); however:
      Version of libgtk-3-0:amd64 on system is 3.18.9-1ubuntu3.3.
    
    dpkg: error processing package opera-stable (--install):
     dependency problems - leaving unconfigured
    Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
    Processing triggers for desktop-file-utils (0.22-1ubuntu5.2) ...
    Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20180209-0ubuntu1) ...
    Rebuilding /usr/share/applications/bamf-2.index...
    Processing triggers for mime-support (3.59ubuntu1) ...
    Processing triggers for hicolor-icon-theme (0.15-0ubuntu1.1) ...
    Processing triggers for shared-mime-info (1.5-2ubuntu0.2) ...
    Errors were encountered while processing:
     opera-stable
    
  • I'm having the same issue with the same data. Have you figured it out yet?

  • Actually I have found a work around. Opera hasn't fixed this issue yet, and probably won't. Its a shame that Opera lies and says it supports Ubuntu 16.04, but in fact, it does not. Work around is located here at the bottom by kmod:
    https://forums.opera.com/topic/41676/solved-missing-dependency/10.

    Short answer is you have to rebuild the deb pkg citing version 3.18.9 instead of 3.19.12. I have personally done this with no effects on browsing so far.

    Cheers!