Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Latest Update Broke the Opera UI

  • Seems as if not everyone knew about this problem. 😉
    I've read this thread but couldn't believe that it's a general problem.
    Was about to switch to opera after being driven away from firefox but things aren't better here.
    Gonna rethink switching.
    Perhaps try Opera again in a year or so.

  • @pyromantiker Even with this bug, things are much better in Opera than they are in firefox. Honestly, if you were really going to switch, then you'd switch. And if you were looking for a reason to not switch, then you found one. I doubt that this specific issue is the reason you'd not make the switch. It will get fixed in a matter of days, not a year. I'm sure you weren't trying to troll, but your comment reads that way.

  • @ctrlaltdel I've not yet experienced issues with the font size in Speed Dial.

    My enabled Start Page settings are only 2: 'Adjust animations for slow hardware' and 'Automatically adjust columns...' under opera://settings/?search=start+page.

    Under font (opera://settings/?search=font) I have 'Font Size: Medium', 'Page Zoom: 100%' and custom font size settings.

    Those settings could be why I do not have issues with font sizes, currently. I had issues in the past, which is why I adjusted them some time ago.

    2142c07f-7aab-41bc-8a90-039779c31c82-image.png

  • @pyromantiker I often say I'm about to jump ship from Opera to some other browser. The thing is.., Opera is better than the alternatives.

    Firefox was good in the past when addons, scripts and customizability made it stand out from all the other browsers but now, Firefox is just as dull as most other browsers. Opera has a few features that make it stand out from the rest, which is the only reason I persist with Opera despite the lack of consideration Opera's developers give to the needs and requests of its userbase.

    Sadly, there is a trend among software developers -- a trend that began 4 or 5 years ago -- to disregard the wants of the userbase and to behave with authoritarian vigour. The message from developers is: you get what you're given; what we think you need is more important than what you know you need; mother knows best.

    Stick with Opera. Leave Opera. Opera doesn't care.

  • The use of right click and his menu is mandatory for me, so maybe i come back the day they fix that.. i don't use many of the fancy option and features of opera.

  • Hello,

    Whenever I right click anything in this browser, the menu that is supposed to come up is simply invisible. And I mean invisible, I can click it but can't see it.

    Not only that, but it seems that other pop up menus are affected as well.
    For example, when clicking the 3 dots here the menu is invisible too. I can click it, and whatever my cursor randomly lands upon will work, but I can't see what I'm clicking.
    fae8a24b-7ca8-4877-a9ea-ecf2b7957d5b-image.png

    Any help will be greatly appreciated!

  • Yep, same issue as all of you. Enabling hardware acceleration doesn't work, I guess I'm gonna install a previous version 😕

  • Just for the kicks, stable version 71.0.3770.198 doesn't solve the situation, still having all popup menus hidden to the naked eye, but the mouse can click on them and trigger actions.

  • Given I don't expect the fastest of resolutions, I went ahead and downgraded to 70.0.3728.95 (available here) and I got all pop-up menus back.

    For those that hardware acceleration is not an option, this is the alternative for now, I guess. Hope this helps.

  • @davidrmf

    Thanks, David. Downgrading is really the only choice for most users. Personally, I've never seen a browser release that literally kills the main functionality of itself before.

    And then updates follow that do not fix the issue.

    It is really bizarre. It isn't some minor issue like not being able to access history or maybe a new tab not closing or something.

    It's the main Opera menu and right click context menu functionality that is trashed and Opera can't seem to find a resolution for it. It has nothing to do with Chrome because, as we all know, Chrome isn't Opera.

    I don't know. Maybe the developers of Opera have just encountered an issue that they aren't educated or intelligent enough to fix. It could happen, you know. If no one working on Opera is smart enough to fix something, who is going to do it?

    The problem may never be corrected, which would be sad.

  • @minivan said in Latest Update Broke the Opera UI:

    @pyromantiker Even with this bug, things are much better in Opera than they are in firefox. Honestly, if you were really going to switch, then you'd switch. And if you were looking for a reason to not switch, then you found one. I doubt that this specific issue is the reason you'd not make the switch. It will get fixed in a matter of days, not a year. I'm sure you weren't trying to troll, but your comment reads that way.

    Hang on a second; let me make sure I understand this. You just called a poster a troll that said he would wait before using Opera after reading post after post after post after post about how Opera doesn't work properly.

    People are complaining and looking for solutions in every other thread. Opera doesn't work any longer. And here you are calling someone who thinks he will wait until things are worked out before switching to Opera a troll?

    If anyone is trolling, it is you. What you said to this poster doesn't make sense. Why would someone willingly install a browser that doesn't work? That would be idiotic.

  • @vr51

    Thanks, VR51. It's odd. The labels on the Speed Dial categories and the text on the Speed Dial entries are very large and all merge into one another. This issue was never an issue before upgrading to 71, just like the other problems.

    I thought maybe it was the same for everyone. Thanks for responding with the information you provided.

  • Heads up.
    I thought (foolishly) that I would give Opera Beta a try only to find no access to any menu at all. No settings etc. Any attempt to uninstall/remove has resulted in failure and the following message:

    Detailed errors from the package manager follow:

    snapd operation finished with error cannot perform the following tasks:

    • Save data of snap "opera-beta" in automatic snapshot set #6 (cannot create archive: tar: 79/.config/opera-beta/oauc_pipe: socket ignored (and 31 more))
  • @rob-bob-dave
    Update:
    dpkg --list
    shows no sign of opera-beta or opera to uninstall through the command line

  • @rob-bob-dave

    Snaps are self contained packages. There is nothing installed when you use a snap.

    Try to install from the repo. Add this line to your sources

    deb https://deb.opera.com/opera-beta/ stable non-free
    

    See here for Snapcraft (Snaps): https://snapcraft.io/opera-beta

    See here for .deb packages https://www.opera.com/computer

    See here for Opera Beta .deb packages https://www.opera.com/computer/beta

    Click the big blue download button, not the snap/rpm links.

  • Hello dear community,

    I am using Opera with the current 71.0.3770.198 version. But since about 2 or 3 update I got these problems:

    • Right-Clicking does not work, when I click with my right mouse button no menu appears. And opera kinda freezes, freez is gone when I switch tab or switch window with alt+tab
    • The Opera-Menu doesn't open when I click on it
    • when you have to many bookmarks there is a >> symbol on the right, which normaly shows the remaining bookmarks. Clicking on it doesn't work either
    • when I am on the bookmarks page I can't use the button in the left bottom corner to backup the bookmarks

    Are there others with the same problem?

    Maybe some developer could look into this, for a fix in future updates.

    Rest is running very good, well except the problem with libffmpeg.so (https://forums.opera.com/topic/30254/solved-video-playback-issues/7) but that is another story 😉

    Oh, and I use Fedora 32, if that info would be relevant.

    Kind regards 🙂

  • Hoi,

    I started Opera via terminal and got some information from there:

    $ opera
    [14507:1:1002/151111.492674:ERROR:child_thread_impl.cc(806)] Receiver for unknown Channel-associated interface: search.mojom.SearchBouncer
    [14509:1:1002/151111.522605:ERROR:child_thread_impl.cc(806)] Receiver for unknown Channel-associated interface: search.mojom.SearchBouncer
    [14528:1:1002/151111.549248:ERROR:child_thread_impl.cc(806)] Receiver for unknown Channel-associated interface: search.mojom.SearchBouncer
    [14539:1:1002/151111.576064:ERROR:child_thread_impl.cc(806)] Receiver for unknown Channel-associated interface: search.mojom.SearchBouncer
    [14540:1:1002/151111.593008:ERROR:child_thread_impl.cc(806)] Receiver for unknown Channel-associated interface: search.mojom.SearchBouncer
    [14565:1:1002/151111.638200:ERROR:child_thread_impl.cc(806)] Receiver for unknown Channel-associated interface: search.mojom.SearchBouncer
    [14588:1:1002/151111.814029:ERROR:child_thread_impl.cc(806)] Receiver for unknown Channel-associated interface: search.mojom.SearchBouncer
    [14479:14487:1002/151128.756607:ERROR:x11_software_bitmap_presenter.cc(136)] XGetWindowAttributes failed for window 58720281
    Xlib: sequence lost (0x102be > 0x2c0) in reply type 0x41!
    [14479:14487:1002/151137.780813:ERROR:x11_software_bitmap_presenter.cc(136)] XGetWindowAttributes failed for window 58720284
    [14896:1:1002/151208.922613:ERROR:child_thread_impl.cc(806)] Receiver for unknown Channel-associated interface: search.mojom.SearchBouncer
    [14909:1:1002/151209.526865:ERROR:child_thread_impl.cc(806)] Receiver for unknown Channel-associated interface: search.mojom.SearchBouncer
    [14919:1:1002/151209.790920:ERROR:child_thread_impl.cc(806)] Receiver for unknown Channel-associated interface: search.mojom.SearchBouncer
    [14929:1:1002/151210.002817:ERROR:child_thread_impl.cc(806)] Receiver for unknown Channel-associated interface: search.mojom.SearchBouncer
    [14947:1:1002/151214.648826:ERROR:child_thread_impl.cc(806)] Receiver for unknown Channel-associated interface: search.mojom.SearchBouncer
    [14479:14487:1002/151221.587034:ERROR:x11_software_bitmap_presenter.cc(136)] XGetWindowAttributes failed for window 58720297
    [14479:14487:1002/151226.787002:ERROR:x11_software_bitmap_presenter.cc(136)] XGetWindowAttributes failed for window 58720303
    [14479:14487:1002/151229.134732:ERROR:x11_software_bitmap_presenter.cc(136)] XGetWindowAttributes failed for window 58720306
    [14981:1:1002/151236.179970:ERROR:child_thread_impl.cc(806)] Receiver for unknown Channel-associated interface: search.mojom.SearchBouncer
    [14986:1:1002/151236.186421:ERROR:child_thread_impl.cc(806)] Receiver for unknown Channel-associated interface: search.mojom.SearchBouncer
    [14479:14487:1002/151243.197061:ERROR:x11_software_bitmap_presenter.cc(136)] XGetWindowAttributes failed for window 58720321
    [14479:14487:1002/151309.957573:ERROR:x11_software_bitmap_presenter.cc(136)] XGetWindowAttributes failed for window 58720324
    [15022:1:1002/151311.215449:ERROR:child_thread_impl.cc(806)] Receiver for unknown Channel-associated interface: search.mojom.SearchBouncer
    [15023:1:1002/151311.217449:ERROR:child_thread_impl.cc(806)] Receiver for unknown Channel-associated interface: search.mojom.SearchBouncer
    
    

    this seems to be interesting:

    [14479:14487:1002/151128.756607:ERROR:x11_software_bitmap_presenter.cc(136)] XGetWindowAttributes failed for window 58720281
    

    and this:

    Xlib: sequence lost (0x102be > 0x2c0) in reply type 0x41!
    

    Maybe someone with more experience could look into that.

  • I have been noticing that, the click-tab-to-go-to-page-top funcion is apparently being overwritten by the go-to-page-top button you can find in some sites. The only pages the function won't work are those that have this button. It really bothers me as these pages are mainly forums in which I constantly go up and down and I'm too much accustomed to this function. This isn't as much an attrocity as the problem with the menus, but they should correct it.

  • @joklok

    Try enabling "hardward acceleration" in the settings menu. I had the same issue and this fixed it for me. (CentOS7; Opera71)

    I found this issue and solution above (posted by KetoKelo)

  • @brotherj4mes Yep, enabling hardware acceleration helps, but this is a temporary fix.
    Still thank you for your reply.