Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Youtube video quality 144p only

  • For some YouTube videos (not all) the video quality is defaulting to 144p and I can't change it. There is no other resolutions on the list.
    This problem is not present in other browsers including the normal Opera.

    I am using Opera GX version: LVL2 (core: 68.0.3618.206)
    Windows 10 version 10.0.19041

    I found a thread on Reddit and tried all suggestions from there but it didn't work.
    the things I tried:
    disabling all extensions
    disabling opera://flags/#disable-accelerated-video-decode flag
    disabling hardware acceleration
    all the options in opera://flags/#use-angle flag.

    An example of a video with this problem:
    https://www.youtube.com/watch?v=PAnKl7862qc

  • The same thing happened to me. The only way the video will stop buffering is to play at 144p. I use the same browser and when I first got opera gx, it was fine, but then I imported my bookmarks, history, and everything else from Google Chrome, and it started doing it. For me it happens on every video. I have a pretty good computer and good internet. At first I thought Youtube would come in and say, "Find out why your video quality is bad..." or whatever like they do if the video quality gets bad at night, but nothing. On Google Chrome I did not experience any problems, and the Opera GX browser is really cool and I wanna keep using it, but for Youtube, unless I wanna watch a potato, I have to go back to Chrome. Please help to find a fix!

  • I was going to post about my internet connection using Opera GX, but after I made a test and discovered that what was limiting my connection was actually the vpn connection I enabled. Check if you have vpn enabled and try to disable it and try again. Or it could be about a extesion for youtube, there are extesions for opera that automatically changes the resolutions of your videos to your favorites resolutions. Well, this is all I can do to help for now.

  • @lipe117 Thanks! I was using the free VPN that you can enable in the settings of the browser, and I didn't think it would affect the speeds all that much. I tried turning it off and now youtube works great!

  • @mgpmars I was also using that vpn, and well, it is just ridiculous how much it affects the connection. I mean, I have a 60 mb/s download internet, and with vpn enabled it was reduced to as little as 1 mb/s

    I think maybe there is a way to use vpn and still get more connection speed, but I will avoid activating it while I watch videos.