Opera keeps me asking for my admin credentials every couple of minutes

  • I am using Opera 21 on OSX 10.6 Snow Leopard (as far I know, this is the most recent version of Opera running on this system).

    Nevertheless the auto-updater always tries to update install a newer version, and keeps me asking for my admin credentials in order to install the new version. This happens every couple of minutes, and in effect makes working with Opera impossible.

    I have enabled "Show Advanced Settings" in Preferences/Browser, but still there is no entry in the preferences which would allow me to disable the silly auto-update....

    Is there any way to switch it off, or do I have to give up Opera completely?

  • Opera 23 is the latest (stable) version for Mac (and Windows), so you are not up to date, But whether it's compatible with OSX 10.6 I have no idea, as I don't use Macs. I'm sure someone more knowledgeable of the Mac version of Opera will chime in soon and enlighten you.

    Or you could go ahead and download the latest (stable) version yourself from the link below and use it to update your current version.

    http://www.opera.com/computer/mac

  • Hello,

    just to make sure, are you certain that the message you're seeing isn't this one?

    Regards,

  • just to make sure, are you certain that the message you're seeing isn't this one?

    Yes, I am. The message you are refering to, is related to the keychain access.

    Actually, the fact that I am asked for the admin credentials does makes sense, because the auto-updater needs admin rights to put opera.app into the Applications folder. That's why I want to disable it.

  • Opera 23 is the latest (stable) version for Mac (and Windows), so you are not up to date, But whether it's compatible with OSX 10.6 I have no idea, as I don't use Macs.

    OK, two points here:

    First, I see that Opera 23 indeed should work with my Mac too, according to the release notes, so I might give it a try.

    But, second, even then this still wouldn't solve my problem in general: Even if version 23 runs on my hardware, this will not guarantee that the next update will work too. I want therefore switch-off the auto-update and, if a new version is available and I decide to give it try, I want to first try out the new version along the old one to see whether it really works, before I update.

    Ronald

  • We will improve this soon. Some work was already integrated yesterday for this.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.