Opera stopped working for lots of sites

  • I was messing with my router DNS configuration and after that (it might be related or not) Opera stopped loading lots of sites. I get this message:

    Connection closed by remote server  You tried to access the address http://www.ihned.cz/, which is currently unavailable. Please make sure that the web address (URL) is correctly spelled and punctuated, then try reloading the page. Make sure your internet connection is active and check whether other applications that rely on the same connection are working. Check that the setup of any internet security software is correct and does not interfere with ordinary web browsing. If you are behind a firewall on a Local Area Network and think this may be causing problems, talk to your systems administrator. Try pressing the F12 key on your keyboard and disabling proxy servers, unless you know that you are required to use a proxy to connect to the internet. Reload the page.
    

    The pages load with other browsers, they are available (one of them is google.com), starting Opera with -pd /tmp does not change this. It is very weird, any ideas what I might do to fix it? I am on 12.16 on Ubuntu 13.10, 64bit.

  • Enabling proxy server make everything work, but slowly. This seems weird. Disabling them stops it from working again.

  • Have you enabled 'Opera Turbo' in 'Settings' by any chance ?.

  • Originally posted by felagund:

    any ideas what I might do to fix it?

    Originally posted by felagund:

    I was messing with my router DNS configuration

    i kinda feel like thats its own answer ... stop messing with dns configs if you have no clue what you are doing

  • Originally posted by serious:

    Originally posted by felagund:

    any ideas what I might do to fix it?

    Originally posted by felagund:

    I was messing with my router DNS configuration

    i kinda feel like thats its own answer ... stop messing with dns configs if you have no clue what you are doing

    Well, I actually had an idea what I was doing (and I saved an old config so I was able to revert any changes). I think it should not have any impact on opera (as other browsers work just fine), I still think it was rather a coincidence (when I route my traffic over VPN, it does not help, so my local LAN setup does not seem to be the culprit).

  • Originally posted by LinuxMint7:

    Have you enabled 'Opera Turbo' in 'Settings' by any chance ?.

    No, I have not as it makes things slower in general.

  • ok, round two ;)
    1) does nslookup work?
    2) same for telnet
    3) define "other browsers" ... eg. not sure if chrome might fall back to googles dns or something
    4) system proxy settings vs. operas proxy settings

    generally hard to say without knowing setup details

  • Originally posted by serious:

    ok, round two ;)
    1) does nslookup work?
    2) same for telnet
    3) define "other browsers" ... eg. not sure if chrome might fall back to googles dns or something
    4) system proxy settings vs. operas proxy settings

    generally hard to say without knowing setup details

    1) yes
    2) yes
    3) firefox and chromium
    4) system has no proxy set up, running opera with privoxy on port 8118 (with default configuration) and pointing http and https traffic over it makes dns lookup in opera work (I used to have it chained with tor but turned that off since it slowes things considerably)

    Originally posted by rilef:

    You might try clearing Opera's History cache of Addresses ("CTRL+F12", then "Advanced", then "History"), and see if this fixes the problem. If not, try specifying your preferred DNS providers in Ubuntu, (thus changing Ubuntu settings from its current none/automatic). Note, you don't have to change your router settings to try this, since your Ubuntu settings will override your router settings. Also, be sure to specify at least two DNS providers in your router or Ubuntu, in case the primary is unavailable.

    Cleaning history does not help.
    Setting DNS to 8.8.8.8 and 8.8.4.4 (google dns) does not work.
    I am pretty sure this is something within Opera, but have no idea what. Tried reinstalling and running with clean home directory but that did not help. It is really weird.

  • @felagund

    Unfortunately, I'm as clueless as you are.
    Nevertheless it doesn't look to be a DNS issue, otherwise the other browsers wouldn't work neither.
    It seems that either your Opera install is messed up or something stays in its way.

    What I would try is to install (USB-option/stand-alone) Opera 12.14 in a new created folder and see if it behaves the same.

  • Hm, weird, I took my laptop to another house that has a different setup and a different ISP and it all works as supposed (sites load without any proxies). Wierd. I will see if it still persist when I get back home.

  • Originally posted by rilef:

    Originally posted by felagund:

    Hm, weird, I took my laptop to another house that has a different setup and a different ISP and it all works as supposed (sites load without any proxies). Wierd. I will see if it still persist when I get back home.

    There are a lot of free public DNS providers out there. You don't have to use Google DNS. A good tool for finding and testing DNS is available from Gibson Research at https://www.grc.com/dns/Benchmark.htm . I've run it only on Windows. You'll need Wine to run it on Linux.

    I normally use my provider's DNS servers, I use google's just for testing, but thanks for the tip.

  • Hm, so the problem lies with my router. It does not seem to depend on its configuration as I used a two-month-old backup and the issue still persists. All other routers (even on the same connection) work fine. Even putting a NAT router behind my home router makes everything work.

    Also, when I cannot load a page, it is immediate with no delay. When I use my proxy to access the site, the site then works even if I disable the proxy afterwards. After restarting opera, it forgets it and I need to use the proxy again. Really weird.

  • Ha, so I incidentally broke my ipv6 configuration and that was the culprit. Fixing ip6 connection fixed the issue. I think only the sites that do not have ipv6 implemented worked.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.