Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Copying the URL from the URL bar should be plain text

  • The "Paste and Match Style" action (keyboard shortcut: cmd-option-shift-V) will generally paste the unformatted plain text URL in the destination app.

  • Is any extension or parameter to modify this behaviour ?

  • Why is this still an issue?
    I have the same problem and it makes me reconsider my webbrowser-choice.
    Is there any fix for that?

  • Same issue here and I have Version:70.0.3728.119 of Opera and System:Mac OS X 10.14.6 64-bit (Mojave on MacBook Pro (15-inch, 2017)) The keyboard shortcut: "cmd-option-shift-V" does work, but thats not a standard behavior people are used to for a URL copy/paste operation. Opera DEV team - kindly enable this link header VS plain text copying option as a feature please?
    Many thanks in advance!

  • I'm so glad I found this thread with others not loving this "feature." Would love to see a enable/disable option ASAP! Thank you for others who mentioned the paste without formatting keyboard commands, that'll work for now at least. Hope this get's addressed soon!

  • hey, has anyone found a solution for this?

    thx

    g

  • OSX has a keyboard shortcut to paste text in plain-text:

    ++V (CMD + Option + V)

    With this keyboard shortcut, the address is always pasted as an URL instead of a rich-text link element.

  • I may have found a work around for pasting into iMessage. Right click in iMessage (where you intend to paste), scroll to substitutions , mark Smart Links with a check mark. iMessage workaround copy.png

  • Never mind my post about a work around, it only worked once. Damn.

  • Command-option-shift-V does work, but it took a lot for me to find this thread and suss that out.

    I don't know any other app that does this -- no browser that I know of copies the formatted URL and shows only the title. Since it's apparently a "feature" in Opera, it should be something we can turn off via a preference. Might seem like a small thing, but it's led to a lot of hair pulling, especially when I'm pasting into iMessage. I am seriously considering switching to Firefox over this.

  • I'm done working around this. (I've been clicking in the URL, which highlights it, clicking again to get a cursor, moving to the end and adding a space, and then copying that. Which pastes as text but not as a link, at least in Apple Notes, so it's still a problem.)
    Going back to Firefox for my work browser.

  • @minerva42
    Instead of pasting with command-v, use shift-command-option-v.

    That works for me -- no formatted text, just the url.

Log in to reply