Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Discord Web is Stuck at "RTC Connecting" and Doesn't Allow Voice Chat

  • Hello. Since last month or so with the Opera GX 67, I realized that I was unable to use Discord voice chat because Discord web on Opera GX was stuck saying "RTC Connecting" and wouldn't allow me to neither speak nor hear the other person. I used Discord web on Opera for years without problems, and with Opera GX since its inception. I tried everything (deleted and did a clean reinstall of all my audio drivers, reset/reinstalled Opera Gx and tested without any extensions installed, ...) to fix it, but none of that worked.

    Then I thought of switching to normal Opera (68), and the issue was resolved. Just because of this issue I abstained from using Opera GX and deleted it. I had to put up with the ugly and dysfunctional theme of the Opera (dark theme, the only other option besides the light theme), because of which I was having trouble discerning which tab was my current tab among many open tabs (dark gray on black is a really bad idea).

    Anyhow, yesterday I realized with joy that the Opera GX was finally updated to version 68 and installed it right away and uninstalled the normal Opera. But what do I see, the problem is still there. I still can't use Discord web and I had to download the Discord app which I never wanted to use in the first place. I did this because I really can't stand the normal Opera, but you guys seriously need to find what is causing this problem with the Discord web on Opera and fix it as soon as possible since this is a major issue which has been going around for a month.

    Thank you.

  • I also tried flushing and resetting my DNS, deleting and clean reinstalling my network device drivers, and relocating my server country on Discord. I basically tried every suggested solution I could find on the internet for this issue, however, nothing worked except for switching to the normal Opera browser (or switching to any other browser I guess).

  • It's been days since I posted this here and not a single comment or an acknowledgment. Even with the newest version I still cannot join any voice channels on any server on Discord Web using Opera GX. This is a serious problem that needs to be addressed as soon as possible. Just hearing that devs are aware of this issue and are working for a fix is enough. Isn't it a bit ironic that the gamer-oriented browser Opera GX can't be used with Discord while normal Opera runs Discord perfectly fine?

  • Hi!
    Discord is not working for me too in opera gx, and i want the solution too.
    But i think its beacuse of the VPN service, but the turning off the VPN doesn't help.

  • @Rixxxy Thanks for the reply. I can assure you that the problem is not related to VPN since I never use it and still can't access Discord web.

  • @Unbeknownst Oh okay then, i think we just need to wait for an update to solve our problem.

  • Well, an acknowledgment before the update would be nice since it might take a long time for them to fix it.

  • Update: Since I installed the same extensions on normal Opera and Discord web worked there, I wasn't suspicious of any add-ons, but after some tampering I found out that a particular setting in UBlock origin called "Prevent WebRTC from leaking local IP address" is causing this RTC problem. There is an explanation about that feature here:

    Disabling this feature fixed the "RTC connecting" issue for me.

  • That's not good for me, that wasn't even turned on in my browser, so i don't know.

  • @Rixxxy Well, I'm assuming you have Ublock Origin installed? I was relatively sure that setting in Ublock was causing the problem because I tried enabling it and got "RTC Connecting" error on Discord web and I tried disabling it and my voice connection was successful. I played a bit on and off and got the error with the setting on and successfully connected with the setting off. Maybe just try switching it on and off to see if it works? If that doesn't help, there could be some other setting within Opera or more probably within another add-on that you use that is causing RTC issues.

  • Yes i have it installed, but not the uBlock Origin is the problem. I uninstalled it, but it didn't do anything with RTC Connecting error, so i don't know what causes the problem.

  • @Rixxxy I think I found the problem.

    When you go into the Opera Settings, like I had, there's a whole WebRTC area. (
    For me, at least, this setting was set to Disable non-proxied UDP. (

    Switching this to the recommended setting or anything else should solve your problem after closing Opera GX and re-opening it, at least for me. If this didn't help you, then I'm very sorry.
    (I actually had the same problem and tried fixing it myself, since nobody else has been a help.)

  • @xscalamity Thanks for the advice, that helped me too! 🙂

  • @xscalamity thanks, you saved my life

  • @xscalamity Great! Thanks!

  • @xscalamity for me, it worked up to the part of "switching to recommended setting" (I didn't try the other options), everytime I close my browser, the setting changes to "Disable non-proxied UDP" again. So when I reopen, I have to chance to recommended once again. Tuff but alright.

  • @xscalamity Thankyou, it worked for me too

  • @xscalamity I was almost gonna think about using Chrome again thanks so much!

  • @xscalamity In a way, it did work. Whenever I exited out Opera, it went back to the default setting. So I re-selected the recommended setting and didn't exit Opera out. And, it worked. (GX)

  • @unbeknownst Search for webRTC in the settings, choose the recommended option.

    This solves the issue for most, if it doesn't, try selecting other options.