Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Wallpapers do not get installed!

  • When I click install wallpaper, it says "installed" but when I refresh the page it says "add to opera"
    as if i did not install it.. looking in the settings there are no installed wallpapers..
    Im using latest Opera portable x64..

  • What specific wallpaper are you adding? There are a few on the addons site that are for older versions of Opera where they're packaged differently. Those won't work in current Opera. But, there's a way to fix them.

  • @burnout426 I tried five different wallpapers including ones that were under the "Recommended" by the Opera store.. Its the weirdest thing because I cant seem to find anyone else having the issue..
    The green button says "installed" but the goes right back to "Add to Opera" after refreshing the page and the browser does not detect anything..

  • Can you provide a link to at least one you tried?

    Im using latest Opera portable x64..

    Do you mean the Opera Portable from opera.com or one from portableapps.com?

  • https://addons.opera.com/en/wallpapers/details/water-7/ installed fine for me in Opera 67.0.3575.115 64-bit on Windows 10.

  • @burnout426 umm i downloaded a long time ago but im 90% sure that it is legit Opera because the exe file is named Launcher.exe
    I think the Portableapps version would rename it to something like "Opera-portable" or something like that..
    It also is able to update on its own..

    [Edit] yeah.. make that 50% sure.. lol :s I have no real clue..
    How can I find out for sure?

  • In the install folder, the structure should look like this if it's from Opera:

    - 67.0.3575.115
        opera.exe
    - profile
        - data
            Preferences
    launcher.exe
    

    Where is this portable install installed?

  • @burnout426 Ok I know now that I has the official Opera.. It was put in my flash drive since forever...
    But i think I somehow disabled the Wallpaper functionality then forgot about it..
    It doesnt concern me now since I know it is not a bug and its just me (wallpapers aren't a priority)
    Just consider this issue closed..
    Thank you for your time..

Log in to reply