Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Not responding after update

  • @burnout426 Hi!

    I'm having the same issue. How do I disable sync?

    Opera doesn't work long enough to go to settings. Can this be done outside of Opera?

    Thank you!

  • @jarodsafehouse71 If you can do it before Opera crashes, click the sync icon that's on the right side of the address bar and choose to sign out. Or, try going to the URL opera://settings/people to sign out if you have to.

  • @burnout426

    Thank you for the fast response, but unfortunately, I can't do it quickly enough. I have reverted back to v66 and it's working fine but of course, it automatically downloads the current version. How do I disable auto-update until this is fixed?

    I'm using Windows 10 64-bit with 64-bit Opera 66

  • @jarodsafehouse71 said in Not responding after 67 update:

    How do I disable auto-update until this is fixed?

    In Opera's installation folder, under the latest version folder (66... for you), rename opera_autoupdater.exe to opera_autoupdater.off. If you're going back to 66 by using the installer, you need to close Opera as fast as you can when it starts. Then, check the Windows Task Manager to the opera_autoupdater process. If it's there, kill it first so you can rename the opera_autoupdater file.

  • @jarodsafehouse71 said in Not responding after 67 update:

    @burnout426

    Thank you for the fast response, but unfortunately, I can't do it quickly enough. I have reverted back to v66 and it's working fine but of course, it automatically downloads the current version. How do I disable auto-update until this is fixed?

    I'm using Windows 10 64-bit with 64-bit Opera 66

    I am exactly like you, I installed v66 but when I loaded my last session with 67 for not losing all the tabs it started not responding again. It frezzes so fast I can't disable the sync.

  • I will share that disabling Sync seems to fix the problem. At least It works. I suppose there is a problem with Sync. I guess if I have to Sync for some reason, I can always install 66 over 67 (I downloaded the full file, and it worked!) and turn off the updates. Hopefully, Opera is working at a fix?

  • @burnout426

    I appreciate your help! Thank you so much!

    I don't know what I did, but the latest version is working now ... I was already signed out of sync when 67 was installed last night.

    PC mysteries ...

    Thanks again!

  • You can try this way if you want.

    While Opera is closed of course, use JSONedit to load "C:\Users\yourusername\AppData\Roaming\Opera Software\Opera Stable\Preferences". Right-click on "Sync" and choose "delete selected node". Right-click on "Sync button" and choose "Delete selected node". Save your changes.

    That will log you out of Opera sync. And, if you ever log in again, Opera should (I tested this and checked synced bookmarks afterwards) continue syncing without screwing anything up and wiping out your data. But, no guarantees.

  • same problem on v 68

  • Re: Not responding after 67 update

    Like everyone else on here. Opera is unusable.

    When the browser has opened, you do your first click, it then freezes and says "Opera is not responding", and then you have to forcibly close the program down.

    This is the first time I have installed it in 6 months as windows 10 deleted it when there was a big update.

    I have tried uninstalling and reinstalling Opera 3 times now and it still locks up.

    What I did notice was, it took a good half hour to lock the first time as I was trying to sync and forgotten my password and had to do a password reset. It allowed me to do that and then I noticed all my speed dials had gone from when I last used it 6 months ago on a previous version.

    It sounds like a memory issue here.

    What gives?
    Come on Opera, get it sorted, you're losing a customer here and probably more.