Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

High memory consumption on a specific Microsoft page

  • Good day, folks ..

    Upon opening an 'offending' web page, Opera's memory allocation climbs from some 400 MBs all the way up to some 1.2 GBs. This does not happen with other browsers (Firefox/Chrome). The offending web page is:

    https://docs.microsoft.com/en-gb/previous-versions/windows/desktop/legacy/ms633493(v=vs.85)

    My Opera version is:

    Version: 67.0.3575.8
    Update stream: beta
    System: Windows 10 64-bit

    PS: I have all Opera extensions disabled .

  • @xyzzy-opera said in High memory consumption on a specific Microsoft page:

    PS: I have all Opera extensions disabled .

    Is Opera's adblocker and or VPN turned on? If so, try with those off.

    Is Opera's battery saver turned on and you're running on battery? If so, try turning the battery saver off.

    You can hit shift + esc to load Opera's task manager and it should tell you what process is using all the ram. If it's the GPU process, perhaps you have a buggy GPU driver. If you think that's it, goto the URL opera://settings/system, disable hardware acceleration and restart Opera to see if it helps.

  • @burnout426

    Hi, out of general interest I spent a couple of hours poking around this issue and can say that:

    • It appears to be not reproducible with the Opera's stable version 66.0.3515.44

    • Annoyingly, it's not 100% reproducible with the Opera's Beta version 67.0.3575.8. But it sort of becomes close to 100% reproducible at times -> I can even quit Opera, restart it, and visit the web page and the issue persists.

    Is Opera's adblocker and or VPN turned on? If so, try with those off.
    I've tried with those options on/off and haven't noticed any impact one way or another.

    Is Opera's battery saver turned on and you're running on battery? If so, try turning the battery saver off.
    I'm not running on battery (I never am).

    .. disable hardware acceleration and restart Opera to see if it helps
    I've tried with hardware acceleration on/off and haven't noticed any impact one way or another.

    I'll attach a few screenshots of the 'issue in action', maybe some knowledgeable guy might even be able to figure out something ..

    #1 the initial status
    opera-1.PNG

    #2 the offending page opened
    opera-2.PNG

    #3 the offending page resized to minimum -> interestingly memory allocation gets reduced (to normal or thereabouts)
    opera-3.PNG

    Well, that's all, perhaps it might be worth for a developer having a look at it since it's a 'feature' that has appeared post version 66.0.3515.44.

  • Update ..

    Now this phenomena is 100% reproducible with Opera Beta/Developer versions but NOT the Stable version. With the Stable version, opening the page is quite CPU-intensive, though.

    All in all, this seems to be an interplay involving:

    Here's a link to a Google-Drive video featuring this 'sorcery' in action ..

    Opera-OSK_feature.mkv

    PS. If the fine video doesn't play in your browser, you probably need to enable cookies, third-party cookies included.

  • Haven't even seen the video you provided yet and can already reproduce in Opera Beta and Opera Developer. The on-screen keyboard is definitely triggering the bug in Opera.

  • @burnout426 Good. I'd assume that this issue gets kind of automagically morphed into, say, a bug report by folks reading this forum?

  • @xyzzy-opera Normally, after posting on the forums here and getting confirmation etc., you'd file yourself at https://help.opera.com/en/computer-bug-wizard/, but I got this one for ya.

  • @burnout426 Aha, okay. Thanks and have a nice weekend, cheers!

Log in to reply