Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Operamail launches the wrong browser. How to fix?

  • I've gone into Control Panel, Default Programs in Win7 and changed all the browser related extensions to point to the right one. That one is also the default browser. Yet still it opens the wrong one. Is there some place I can control this? Can I do it in the old Opera 12 browser somewhere or do I need to edit an ini file?

  • Open a command prompt and do:

    start "test" "http://example.com"
    

    Then, try:

    start "test" "https://example.com"
    

    Do those open in the correct browser? If not, then that's why it's not working correctly in Opera Mail.

  • Opera 12 uses handlers.ini in the profile directory. You'd add these entries to it:

    [https]
    Type=Protocol
    Handler=C:\Program Files\Mozilla Firefox\firefox.exe
    Webhandler
    Description
    Flags=4
    
    [http]
    Type=Protocol
    Handler=C:\Program Files\Mozilla Firefox\firefox.exe
    Webhandler
    Description
    Flags=4
    

    for example.

    In operaprefs.ini, you'd have:

    [File Types Section Info]
    Version=3
    
    [Trusted Protocols Section Info]
    Version=1
    

    However, if you try duplicating that for the standalone Opera Mail, it won't work as it doesn't make use of handlers.ini.

    And, if you try adding:

    [Trusted Protocols]
    http="0,0,"C:\Program Files\Mozilla Firefox\firefox.exe""
    https="0,0,"C:\Program Files\Mozilla Firefox\firefox.exe""
    

    to operaprefs.ini like Opera did back in the day before things were moved to handlers.ini, it still won't work.

    So, in short, you have to fix the http and https associations on Windows (in the registry if needed) so that Opera Mail is happy.

Log in to reply