Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

U2F issue on only one site, was working

  • I'm running Opera for Mac 66.0.3515.27. I have a couple Yubikey 5 NFCs. They work great on a number of sites but one of them recently requested that all user disable and reregister their U2F keys. I thought nothing of it until I went to do it and it no longer works. The key goes into the USB slot and lights up, but tapping the key doesn't do anything.

    As a fallback, I tried 2 things: using a key with Google on Opera (this requires that I switch the User Agent to report that it's Chrome for Mac) and works. I also tried installing Chrome to see if the failing site works, and it does.

    Is there anything else you can think of that I would need to do to get this site to accept the key with Opera? The site operator says U2F devices only work with Chrome (which wasn't previously the case) and it's starting to look like that might be true now. It doesn't appear to be the User Agent string, but I can't imagine what it is.

    You won't be able to test this particular site unless you already had an account with the operator, and I suspect most people don't.

Log in to reply