Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]Links does not work as they should. Sometimes. On one specific site, so far...

  • Hi.

    An odd thing happend the other day. I did a search in the store here Jula and got a hits as expected displayed in a grid. Now, I click on one of the items shown to get to its product page but noting happens. I should be able to click on the image/icon or the "title", or whatever you call it, of the product to get to its own page with detailed information about it. Searched for "Ryobi" here, cannot access product "Startpaket One+ 7 delar" directly.
    If I find the product following the treestructure of the site, same thing, I get as long as the "category"-level but no further, can't access the product page. On the other hand, if I right-click on the product icon and select "open link in new window" (or tab) it works as it should, I get to the page I want to go to.
    Next weird thing is that, on the startpage, if I click on one of the products there, categorized as "todays deals" or "new prodcuts" or something like that, THEN it works as it should!?

    I found the cookies for this site in Settings, deleted them, restarted the browser and tried again with the same result, not working. I haven't deleted ALL browser history yet, might make a difference?
    I cannot replicate this behavior with Google Chrome. Have not tried any other browser. Running 65.0.3467.78.

    Any thoughts?

    BTW, I think Opera is a great browser, keep up the good work, not gonna loose me that easy... 😁

    //Roger

  • So, you're saying if you goto https://www.jula.se/search/?query=jul and left-click on the first result, it won't do anything? If so, I was able to reproduce in Chrome with uBlock Origin enabled and in Opera with its adblocker enabled. I'm assuming it has something to do with adblocking then.

  • @burnout426

    /.../ " if you goto https://www.jula.se/search/?query=jul and left-click on the first result, it won't do anything?" /.../
    Correct.

    Just like you stated it has something to do with adblocking. I use Operas internal one. I was fiddling around with it and discovered that the tracer-thingy is the culprit. Doesn't matter if the adblocking part is on or off but if I turn off the "tracerblocker" it works as it supposed to. Thanks!
    Been using different kind of blockers on several browser through the years but this is actually the first time any of them has given me any problem. At least of this "magnitude" in lack of better term. Anyhow, thanks for the help!

    //Roger

Log in to reply