Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Hardware Acceleration Defeats Frame video rendering

  • Problem with MP4 video rendering and acceleration

    The Virtual Desktop provider Frame responded to a help request about Opera not displaying the browser desktop. The response is quoted below:

    "Frame is also an MP4 video stream, and the issue looks identical to what others are describing. None of the fixes that they show seem to work, however I noticed one user who said that it did work after swapping video cards to an older model. With that, I then found that if I disable hardware acceleration in Opera settings (which disables GPU rendering) that the issue does not occur. Doing the same, although not an ideal fix, will resolve the issue until Opera fixes the way that they handle rendering. To disable the setting do the following:"

    1.Open Opera and press Alt + P
    2. In the Settings window, scroll down and un-check the checkbox labeled Use hardware acceleration when available.
    You do not have to press any OK buttons to save the settings. The settings are saved automatically. But the settings take effect only upon restarting of the Opera browser.

  • Thanks. Just a heads up or are you having the problem too?

    What OS? 64-bit or 32-bit OS? What GPU? What driver version? What version of Opera? 64-bit Opera or 32-bit Opera? Website for Frame? How to test?

    (For the OS, launch Chrome and goto chrome://version to get the full OS details.)

    Goto the URL opera://gpu to see if there are any workarounds for the GPU driver that stand out.

    After trying use Frame, goto the URL opera://media-internals and expand the section for the player (they said it's an mp4, so it should show up). Then, look to see what errors it gives.

    Goto the URL opera://flags and reset all flags. Maybe opera://flags/#enable-gpu-appcontainer is turned on and is breaking things. If that doesn't help, play with these flags:

    • chrome://flags/#ignore-gpu-blacklist

    • opera://flags/#use-angle

    • opera://flags/#d3d11-video-decoder

    Also, see https://peter.sh/experiments/chromium-command-line-switches/. There are command-line switches you can pass to Opera's launcher.exe to control GPU stuff. For example: https://peter.sh/experiments/chromium-command-line-switches/#disable-gpu-driver-bug-workarounds and https://peter.sh/experiments/chromium-command-line-switches/#disable-gpu-sandbox.

    Besides that though, it's probably a real issue with your GPU and or its driver. Some setups are just not supported when hardware acceleration is enabled. Try upgrading your driver.

    Also, test in Chrome, Vivaldi, Brave, and Chromium-based Edge to see how they behave.

    Also, test in Opera Beta and Opera Developer at https://www.opera.com/download. Maybe it's a bug in Opera or Chromium that's already fixed in those builds.

    Also, test that h.264 support is enabled at https://html5test.com. Check h.264 under "video codecs" under "streaming" too.

    Also, make sure the video at https://bitmovin.com/demos/drm plays. And, make sure that MSE and EME are enabled undeer the video on that page. If you have to disable hardware acceleration to get things to work, then of course, it's a GPU/driver issue that Opera has.

    Also note that unlike Chrome, Opera uses the Windows Media Foundation to play h.264 + aac videos (mp4s). If WMF support is messed-up on our Windows, that could break things in Opera while things still work fine in Chrome (but should still fail in Vivaldi etc.).

    Another thing you can do is to test with a fresh profile of Opera. Download the Opera installer, launch it, click "options", set "install path" to a folder named "Opera Test" on your desktop, set "install for" to "standalone installation", uncheck "import data from default browser" and install. Test in that Opera, but do not enable Opera Sync, do not install any extensions, do not enable VPN, and do not turn on the adblocker.

Log in to reply