Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Still need fix for pages showing blank white in Opera for Mac

  • I can't upload a screen shot here of what I'm talking about, but it's plain to see, no pun intended. I have two Macs, one is a late 2009 Mini presently using OS 10.11.9 and Opera 65.0.3467.78; the other is a Mini late 2012 now using OS 10.15.2 and also 65.0.3467.78. I've done all the usual: turning off extensions, ending the GPU process task, etc. Hours upon hours of maddening failure. This problem is more apparent on the older Mac but happens on both and has persisted through many updates of both OS and Opera versions. I'm not a power user, just surf and mild personal usage. After repeated refreshings of pages (happens just about with every kind of site) it may stop, but always comes back, never stays away. Good people of Opera, please help your users with this; at least this user. I've struggled with this for months. I've never seen a browser do this or have such a persistent problem that's gone unaddressed and not fixed. Thanks for giving it another good look. I see that this is a problem that's been reported for many years now. Please fix it once and for all.

  • Hi,

    I've read about that time ago, maybe it was you too.

    Did you try on a clean profile?¿

    Follow this steps to do it.
    Rename also the Cache folder.

    Here you can find related info, even about the same problem.

    And here, the better method despite it's a Temporary Profile.
    I don't know how to modify it and create a Shortcut for testing purposes.

    Maybe you can find it or research about.

    --
    "Off Topic Tip"
    Follow the Signature's Backup | Reset link.
    Take the opportunity to start a Backup plan and even create a Template Profile.

    SyncBack | Synkron helps.


    Windows 7 (x64)
    Opera Test profile | Back up | Reset

  • @albertschepis I think I stumbled upon the problem/solution. I went to System Preferences > Opera, then changed Opera Alert Style (to): None. Restarted Opera and so far so good. Let me know how or if this works for you.

  • Yes, I have the same problem.

  • I apparently solved this issue at last by disabling the AdGuard extension that was installed on my Opera browser. You could possibly try to remove some of your Opera addons and check.

Log in to reply