Opera is awfully big

  • Hi, I installed Opera for linux to my home and work workstations and everything works like a charm, but then I installed it to my laptop and the window and pages are awfully big. Of course I can outzoom the page, but the window (program) itself are still for giants.
    My laptop is 14" inches screen with 1920x1080 resolution and distribution is Linux Mint 17 (as is on my other workstations)
    Here is a picture for demonstration: http://kaori.asuna.eu/opera.jpg

    Does anybody have any idea about whats wrong?

    Thanks

  • Opera Developer supports high DPI displays, and it seems to think you have one. I think this is a known bug, but I'll forward it to our Linux people.

    Edit: You can try using --force-device-scale-factor=1 on the command line to disable it.

  • Yes, that helped, thank you ^-^

  • Grrrr i have a similar problem.
    im using opera 25.0.1583.1 on kubuntu 14.04 and it was working really great.
    all of the sudden without changing any setting nor adding any extension (probably disabling one) now the interface (and the pages) looks really bigger (which bothers me a lot) but also i had problems with previews and such.
    looks like the hidpi was activated because i had to enable "enable-hidpi-preview" for tab previews to see them AGAIN.

    anyway im executing opera with this flags:
    -high-dpi-support=0
    -force-device-scale-factor=1
    and still the same
    and i've checked that i write them right, i even tried with one and two dashes before the flag
    -force-.... and --force

    force-device-scale-factor 1+ works. but 1- doest
    http://screencloud.net/v/ayja

    i cant find where to disable hidpi support. ive already searched for info on chrome and opera about it. even scanned the files in the config folder.
    halp plz?

  • News:
    i just tried to do the basic: check for an update.
    when i checked the web the last version was 25 and published today, but i had the same version, and i dont reminded downloading it. and then i reminded..automatic updates..... thanks...
    uninstalled, presserved the config, reinstalled 24 agian, and voila, works again..
    yay, so its a bug on 25.
    also, it seems to make my whole system very slow ... very. opening konqueror or one app will take like 2 minutes (and no cpu or disk seems affected)

  • The DPI detection has changed. Before Opera detected DPI based on a heuristic, checking your screen size and resolution. This lead to many problems with people who have high-resolution but small screens, but love things to be small anyway.

    Opera now uses the font DPI setting (from GTK/Xft) as guidance on what DPI to use, which from our tests seems to be a much more likely approximation for most use cases.

    If you're not happy with that, you can:

    1. Change the font DPI setting on your system, so that Opera will follow

    2. Start Opera using --alt-high-dpi-setting=96

  • Thanks! quick and useful comment.
    Just a doubt.
    how do i do 1) (change system dpi) i cant find it anywhere.

    option 2 works great! thanks!

    bad part is that it still hogs the cpu.
    it leaves kde4 at 100% all the time http://screencloud.net/v/9PpW
    (i have 8 cores so the process only reaches 12-18% top)
    but still makes the whole system unresponsive for long periods of time

  • From your comments I'm guessing you're using KDE. It's in kcontrol under 'Fonts', I forget if it's directly in the main screen or you have to click some button to get there, but there should be a DPI option.

  • Yes im using KDE, thanks, i should have googled it. It worked, but still it freezes the whole system.
    I'll open a new thread to not hijack this one.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.