Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Linux login gone...

  • Have just installed Opera on Opensuse Leap 15.1, x64, and logged in and got syncing working.
    I use 2 profiles with Chrome, so endeavoured to set up the same in opera, by creating 2 directories, with 2 shortcuts on the Desktop, starting similar to: /usr/bin/opera "--user-data-dir=/home/data/_data/Opera/Secondary", (seems to work) and similar for the first, but....
    Have now lost my option to login and sync, totally. ie there is no syncing or login options anywhere to be found.
    Have even tried just running the executable, without options, which uses the default directory (home/.config/opera) but still no option to login...

  • Opera does not support multiple profiles.
    There is only one profile available and that has all the info about sync etc.

  • I realise that Opera doesn't support multiple profiles (neither does Chrome, it works anyway.... and there are several reports around that it can be got to work, on Opera...), but regardless of that, even with a "clean/default" profile, I still get no login option...

  • Chrome does support multiple profiles. I have 2 at work 😛 and I will post a screenshot once I get there if you want.
    Long story short, opera does not support the --user-data-dir=. Try deleting ~/.config/opera-stable and start fresh.

  • @jimunderscorep
    Yep, I know Chrome does (as I also have 2), fairly sure it's not supposed to, though...
    Looks like I am still looking for another browser, then, as I need 2 profiles, and Chrome is not working properly with a few things.... and is a memory/resource hog...
    Don't particularly want to use Firefox...

  • What about chromium then? What are the "few things" that do not work in chrome but work on opera?

  • @jimunderscorep
    "Few things" are generally authentication issues..
    eg Trying to connect to the local print server (CUPS), and changing any configuration fails, as I never get a prompt to login, but Firefox works fine... Popups are allowed...
    Message to enter username and password, but no form/entry area to do this...

  • Well... I do not use cups, so I have no idea about its web interface.
    But I do use transmission-daemon that has a credentials protected web interface, and that one works fine, on all my browsers. It is not on https.

    Firefox
    2019-10-17-173834_1280x1024_scrot.png

    Chromium
    2019-10-17-173714_1280x1024_scrot.png

    Opera
    2019-10-17-173732_1280x1024_scrot.png

Log in to reply