Auto Update Disable Option Gone

  • Opera 18, every time I open it, it hogs my complete bandwidth for about 20 minutes whilst it does some auto update.

    I am having to set up some bandwidth shaping on my router to get around this, however it's really annoying.

    Either the option to switch this to manual has been removed which is bad, or it has been moved somewhere impossible to find, which is less bad, but still bad design.

    Can anyone help clarify if the option is still there and if so, where?

  • There's no way to disable the program autoupdate AFAIK, but that would not be hogging your bandwidth for 20 minutes every time you open it. The download is about 30 Mbtyes whenever an update is available.

    Opera 18 was launched on 19th November, and updated on 6th and 16th December — that's all AFAIK.

    See the Desktop Team Blog for details of all updates.

    What I suspect is the culprit in your case is speed dials or extensions. How many speed dials do you have?

  • It should be possible to delete opera_autoupdate.exe or redirect autoupdate.geo.opera.com in DNS to another host.

    You could also look into disabling preloading of Discover conents or redirecting api.recsys.opera.com altogether.

    Bandwidth shaping (queues) will decrease your throughput as all traffic is analysed for the need to be queued.

  • Originally posted by wcndave:

    Can anyone help clarify if the option is still there and if so, where?

    Hi Wcndave, to disable the "auto-update" feature, add the command line switch as follows: "...\launcher.exe" --disable-update, or (as J7nj7n has mentioned above) you can just rename the "opera_autoupdate.exe" file to e.g. "opera_autoupdate.ex" - in both cases it should stop working, I have checked it in all recent Opera's streams: 18, 19, and 20, and this works.

  • I use opera infrequently when I need to do testing in it.therefore I would not be surprised to get updates almost every time.

    30mb would be about 20 minutes so that sounds right.

    I have no dials or add ins

    The solutions are really no go for Joe public compared to a setting which I guess is why opera is still minority browser and I don't need to test in it much.

    I thank you for your answers but urge the developers to think a little more about things like this.

  • Originally posted by wcndave:Can anyone help clarify if the option is still there and if so, where?Hi Wcndave, to disable the "auto-update" feature, add the command line switch as follows: "...\launcher.exe" --disable-update, or (as J7nj7n has mentioned above) you can just rename the "opera_autoupdate.exe" file to e.g. "opera_autoupdate.ex" - in both cases it should stop working, I have checked it in all recent Opera's streams: 18, 19, and 20, and this works.

    sweet. i'll have to try that (my security setup doesn't like the auto updater). thanx

  • Just be aware that security updates ripple into Opera both from Blink engine updates as well as Opera's own development stream. Some of the "in-between, "minor" version jumps" are that very sort of thing, so be conscious of all the implications of what you're doing if/when you block updates. In other words, if you block updates, stay personally aware of the security-patch scene so you don't find out about a vulnerability "the hard way".

  • agreed blackbirdy. my browsers in a sandbox, so that helps ... however, it's the sandbox that doesn't like the autoupdater (which seems to operate externally from opera and breaks the updates). my firewall currently stops the updater, but the pesty thing is still busy trying to connect. so hopefully this will remedy that a little.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.