Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • I have set Opera as the default browser on my PC, which runs Windows 7. When I click on a email link in Outlook, it opens in IE.
    If I change the default browser to Google Chrome or Firefox, the links do open in these browsers. It's just Opera that does not behave like a default browser as far as links in an email go.

  • Go back to "Default Programs" in Windows, choose "Set Default Programs", choose "Opera" and click "Set this program as default". Then, click on "choose defaults for this program" and make sure all the protocols and file types are selected for Opera.

    If that doesn't work:

    • Download the offline package of Opera from

    • Goto the URL opera://about and take note of the install path.

    • Uninstall Opera via programs and features while choosing to keep your data (if you want to keep your data).

    • After Opera is uninstalled, delete the install folder if it still remains.

    • Launch the offline package installer and click "options". Set the "install path" to "C:\Program Files\Opera", set "install for" to "all users", uncheck "import data from default browser", check "Make Opera the default browser" and install.

    • Then go back to "Default Programs" in Windows and make sure Opera has all its defaults.

    Then it should just work. But, to test that things are correct, open a command prompt and enter this command:

    start "Test" ""

    It should then open in Opera. If you get asked what app should open the URL, selected "always use this app" and select Opera.

    Try the same thing with:

    start "Test" ""

    If those both open in Opera, then Opera is configured correctly. If Opera still doesn't open from Outlook, I'd blame Outlook.

    You can also go into Default Programs and choose to set a default by file type and choose the https and http protocols and set them to Opera.