Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Web link in email does not open in Opera the default browser

  • My email program is Microsoft Outlook 2013 running on a Windows 7 Pro machine. I have set Opera as the default browser but when I click on a URL link in an email, it opens in Internet Explorer instead.
    I then set Firefox (the other browser I have) as the default browser and the link opens in Firefox, not IE. I reset the default to Opera but the link will now open in IE.
    What do I need to do to get it to open in Opera?

  • Having the same issue here. Can't find answers and I see nobody answered this question from September. Want to use Opera, but going back to Chrome. My specifics:

    Windows 10 Home (current) on Surface
    MS Outlook (current Office365 subscription)
    Opera (current)
    Chrome (current)

    Problem: When trying to open hyperlinks in MS outlook if Opera (or Opera Beta) are the default system browser, I get an error. However, MS Outlook opens the same hyperlinks if either Chrome, or MS Edge are set as the default system browser. Error attached.
    links in oulook-Opera issue.png

  • Open a command prompt and enter this command:

    start "Test" "https://www.example.com/"
    

    What program opens when you do that? Try with "http" also.

  • @burnout426 interesting, both http&https properly open in whatever is set as the default browser and access the example.com page. verified with opera & opera beta, chrome, and edge

  • @joma92807 Okay. That means things are correct as far as Opera goes.

    I don't have Outlook to test, but see https://www.google.com/search?q=ms+outlook+links+do+not+work for some things to try. One of them suggests that Outlook relies on the html file association to determine what program to open for links. That's weird, but you can try to make sure html and htm are associated with Opera in default programs. You could also right-click on an HTML file, choose "open with", check "always open with this program" and choose "Opera" to see if it makes any difference. Not sure why it would, but you can try.

  • settings might got out of order slightly

    try this in this order..

    1 Exit from Opera or your default browser..

    2 Go to Default Programs in Windows Settings or Control Panel..

    3 Select (Microsoft Edge if Windows 10) - (IE If Windows 7/8/8.1) as your default browser..

    4 Click on the link in your email to make sure - it opens a tab in (Edge - if Windows 10) - Then close Edge.. or - it opens a tab in (IE If Windows 7/8/8.1) Then close IE..

    5 Restart Opera (or your preferred default browser)..

    6 Reset your default browser back to the one you prefer:

    Under Options for your browser, select “Make Firefox (or Chrome, Opera etc.) my default browser”; or

    Go back to Default Programs in Windows Settings or Control Panel and reset the default there..

    Now, click on the link in your email again..

    also take look at this link..

    https://www.eightforums.com/threads/mailto-links-in-browsers-dont-open-up-outlook-2010-email.14277/

    and this link..

    https://www.tenforums.com/browsers-email/88652-hyperlinks-not-working-2.html

  • @joma92807, I have the identical issue of internet links in Outlook 2016 emails or Word docs not opening when Opera is my default browser but opening just fine when Firefox is the default. I get the same error message as the one you got. So far I have not been able to find a fix -- did you ever get it solved? Thanks.

  • @marana said in Web link in email does not open in Opera the default browser:

    @joma92807, I have the identical issue of internet links in Outlook 2016 emails or Word docs not opening when Opera is my default browser but opening just fine when Firefox is the default. I get the same error message as the one you got. So far I have not been able to find a fix -- did you ever get it solved? Thanks.

    An interesting addendum: if I open an email using the mail program that comes installed on my Surface Pro 6 (running Windows 10 Home) rather than using Outlook 365 (which is the version of MS Office I'm using), any hyperlinks in the email open fine in my default Opera browser, so it must be some setting in Outlook 365.

  • I have the same problem.
    When I try to open links from my default Windows 10 Mail Program, I see the "Unable to open https://....." dialog box.

    I have Windows 10 Pro 1809. I use Mail 16005.12527.20152.0 mail client.
    Other browsers work fine.
    However I can successfully start Opera from command line, or from Windows Explorer address bar.
    I even can successfully open links from my MS Word.
    I don't know if the problem on the Opera side or on the Mail software side, but Opera is the only browser that fail.
    I'll be happy to provide more diagnostic info if someone knows how to grab it 🙂

  • @kaatula said in Web link in email does not open in Opera the default browser:

    When I try to open links from my default Windows 10 Mail Program, I see the "Unable to open https://....." dialog box.
    I have Windows 10 Pro 1809. I use Mail 16005.12527.20152.0 mail client.

    I tried in the Mail app (version 16005.12527.20152.0) on Windows 10 OS Version 1909 (Build 18363.657). While Chrome was the default, when I clicked on a link in an email, it asked me what app I wanted to open the link with and Opera was a choice. When I set Opera as the default browser in settings -> Apps -> default apps in Windows, the Mail app didn't asked me and just opened the link in Opera.

    Could just be a bug with the Mail app on the older build of Windows 10 you have. Not sure.

    My Opera is installed to "C:\Program Files\Opera" and was installed with the "All Uses" option (that you get to when you click "options" in the installer), FWIW.

Log in to reply