Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Web link in email does not open in Opera the default browser

  • My email program is Microsoft Outlook 2013 running on a Windows 7 Pro machine. I have set Opera as the default browser but when I click on a URL link in an email, it opens in Internet Explorer instead.
    I then set Firefox (the other browser I have) as the default browser and the link opens in Firefox, not IE. I reset the default to Opera but the link will now open in IE.
    What do I need to do to get it to open in Opera?

  • Having the same issue here. Can't find answers and I see nobody answered this question from September. Want to use Opera, but going back to Chrome. My specifics:

    Windows 10 Home (current) on Surface
    MS Outlook (current Office365 subscription)
    Opera (current)
    Chrome (current)

    Problem: When trying to open hyperlinks in MS outlook if Opera (or Opera Beta) are the default system browser, I get an error. However, MS Outlook opens the same hyperlinks if either Chrome, or MS Edge are set as the default system browser. Error attached.
    links in oulook-Opera issue.png

  • Open a command prompt and enter this command:

    start "Test" "https://www.example.com/"
    

    What program opens when you do that? Try with "http" also.

  • @burnout426 interesting, both http&https properly open in whatever is set as the default browser and access the example.com page. verified with opera & opera beta, chrome, and edge

  • @joma92807 Okay. That means things are correct as far as Opera goes.

    I don't have Outlook to test, but see https://www.google.com/search?q=ms+outlook+links+do+not+work for some things to try. One of them suggests that Outlook relies on the html file association to determine what program to open for links. That's weird, but you can try to make sure html and htm are associated with Opera in default programs. You could also right-click on an HTML file, choose "open with", check "always open with this program" and choose "Opera" to see if it makes any difference. Not sure why it would, but you can try.

  • settings might got out of order slightly

    try this in this order..

    1 Exit from Opera or your default browser..

    2 Go to Default Programs in Windows Settings or Control Panel..

    3 Select (Microsoft Edge if Windows 10) - (IE If Windows 7/8/8.1) as your default browser..

    4 Click on the link in your email to make sure - it opens a tab in (Edge - if Windows 10) - Then close Edge.. or - it opens a tab in (IE If Windows 7/8/8.1) Then close IE..

    5 Restart Opera (or your preferred default browser)..

    6 Reset your default browser back to the one you prefer:

    Under Options for your browser, select “Make Firefox (or Chrome, Opera etc.) my default browser”; or

    Go back to Default Programs in Windows Settings or Control Panel and reset the default there..

    Now, click on the link in your email again..

    also take look at this link..

    https://www.eightforums.com/threads/mailto-links-in-browsers-dont-open-up-outlook-2010-email.14277/

    and this link..

    https://www.tenforums.com/browsers-email/88652-hyperlinks-not-working-2.html

Log in to reply