Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Bookmark bar keeps popping up despite setting none

  • Every few minutes the bookmark bar pops up, although the setting is 'no bookmark bar'. When it switch it off, it pops up again within a short time. This occurs since a few days ago. I never used a bookmark bar.

  • Before you turn it off again:

    • Goto the URL opera://bookmarks and make sure there are no bookmarks in the "bookmarks bar" section. If there are, move them to the trash and then empty the trash.

    • Goto a page (like example.com or something), click the heart icon in the address field, switch the save location to "other bookmarks" and click "done".

    Then, turn the bookmarks bar back off if "switching to "other bookmarks" didn't do it automatically.

    If none of that works, Opera may be having an issue saving to its files in the profile folder (path can be found in opera://about). Or, maybe there's some extension triggering the behavior.

  • Same for me

  • In addition to my above comment, download the Opera installer, launch it, click "options", set "install path" to a folder named "Opera Test" on your desktop, set "install for" to "standalone installation", uncheck "Import data from default browser" and install. Test in that Opera, but do not enable Opera Sync and do not install any extensions.

    Does it stay off then? Try turning it on and then back off. Does it stay off then. Try turning it on, restarting Opera, turning it off, restarting Opera and trying again.

    If you can't reproduce the problem there and you tried my previous suggestion above in your normal install, then your Opera probably might just be messed up. Specifically, something with the "Preferences" file might be messed up.

  • @burnout426 Thank you kindly for your advice, but I think these are merely workarounds for an issue thatshouldn't be there. When I right-click and uncheck 'show bookmark bar' it shouldn't pop up again within minutes. This behavior is new. Everything was OK for years. I did remove all my bookmarks from the bookmark folder, like you suggested, and I can make sure new bookmarks don't end up there, but the real issue is of course Opera neglecting it's own settings. Opera itself would benefit most from repairing this.

  • Mine seems ok, I actually use the BM bar, turned it off and it seems to stay off. I would ( backup ) try a complete fresh install getting rid of anything Opera and see what happens, does sound like it could be an extension conflict??

  • Problems with the bookmarks bar. Someone knows why I deactivate the bookmarks bar and when opening again it operates again it appears activated, no matter how many times I deactivate it.

  • @zauberfritz

    Goto the URL opera://about and take note of the "profile" path.

    Turn off the bookmarks bar and close Opera.

    In the profile folder, open the "Preferences" file with JSONedit.

    In JSONedit under root/bookmarks_bar, there should be a boolean named "show_on_all_tabs" and it should be set to "false".

    Is that value there for you and is it set to false? If it's still set to "true", Opera is indeed not saving your setting.

    While Opera is still closed, set it to false and save your changes.

    Does Opera work fine then? If not, close Opera and delete the "show_on_all_tabs" object and save your changes. Then try again.

    Anyone here use Bitdefender and or Sandboxie? Those are known to interfere with Opera.

    Even if you consider this a workaround, going through these tests might help find what the issue is so Opera can fix it.

    (Note that the bookmarks bar is supposed to come back on now when you add a bookmark to it. So, if you're just doing that, then that's expected. If you shut it off (whether there are bookmarks on it or not) and it just appears when you start Opera without doing anything, then that's definitely something messed up.)

Log in to reply