Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

This video file cannot be played. (Error Code: 224002)

  • Has anyone had issues playing video content. Screenshot 2019-07-25 at 21.56.15.png

    With the exception of Youtube, most websites report an error of being unable to play the video, e.g. see screenshot showing website https://archive.org/details/Stingray.Complete/Stingray.01.+STINGRAY.avi.

    I have confirmed this issue occurs in 62.0.3331.99. I have tried to play the content with and without the VPN enabled. The same errors occur in the Beta version 64.0.3388.0.

    I’ve also tried installing extensions media player and media plus to test if there was a codec issue but neither extension helps.

  • @albertchong I do have this same issue. At first I thought this was because I updated to the Catalina Beta version, but I may be wrong if you have this issue on an older OS version.

    I noticed this when trying to play MP4 files, but it seems like other formats also fail to play. Most MP4 files play just fine for 1 second and then just freeze.

  • @arasthel I’m on Catalina too but I’ve made sure that Opera has full disk access.

  • I got an update on this issue. While the video still freezes after 1-2s with the latest Catalina beta 9 and both Opera and Opera Developer, it only happens when the video is embedded in a website. If I try to open just the video file using Opera, it will play without sound in Opera and just fine in Opera Developer.

    Also, if I go into "opera://media_internals", I can see that there are errors present:

    render_id: 67
    player_id: 5
    origin_url: https://www.tumblr.com/
    frame_url: https://www.tumblr.com/dashboard
    frame_title: Tumblr
    surface_layer_mode: kAlways
    url: https://ve.media.tumblr.com/tumblr_pyasnmwSob1r0uzl6.mp4
    total_bytes: 512345
    streaming: false
    single_origin: true
    range_header_supported: true
    pipeline_state: kStopped
    bitrate: 677310
    coded_height: 720
    coded_width: 406
    demuxer: AVFDemuxer
    found_audio_stream: false
    found_video_stream: true
    height: 720
    max_duration: 6.034
    start_time: 0
    video_codec_name: h264
    video_format: PIXEL_FORMAT_YV12
    video_is_encrypted: false
    video_profile_name: h264 baseline
    width: 406
    info: Selected MojoVideoDecoder for video decoding, config: codec: h264, format: PIXEL_FORMAT_YV12, profile: h264 baseline, coded size: [406,720], visible rect: [0,0,406,720], natural size: [406,720], has extra data: false, encryption scheme: Unencrypted, rotation: 0°, flipped: 0, color space: {primaries:BT709, transfer:BT709, matrix:BT709, range:INVALID}
    event: PAUSE
    video_dds: false
    video_decoder: MojoVideoDecoder
    is_platform_video_decoder: true
    video_buffering_state: BUFFERING_HAVE_ENOUGH
    for_suspended_start: false
    pipeline_buffering_state: BUFFERING_HAVE_ENOUGH
    error: AVC bitstream converter: Could not calculate output buffer size
    pipeline_error: DEMUXER_ERROR_COULD_NOT_PARSE
    duration: 6.034
    seek_target: 1.861919
    

    This is a mp4 container with H264 video and AAC audio.

    I can play other videos just fine, such as a webm container with vp9 video and opus audio.

  • Same problem here, version 63.0.3368.107 and Catalina beta 10

Log in to reply