Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera GX Spell Check Problem

  • I use Opera GX the last 2 days and I noticed that the spell check is not working.
    I 'm using English and Greek, but neither of them has spell check.
    (I tried to re-install and unistall and install again, and to ''add a language'' but it's not working as well).

  • @gprock For English you need to set a specific one like English (USA) for example.

    I could enable spell checker for Greek here.

  • @leocg I cant do that, i click the options for spell check and other language but nothing is happening.

    Edited:
    Χωρίς τίτλο.png

    this is how it looks like to me, the blue screen with the ''Προσθήκη γλωσσών'' its the add language but it doesn't working and the ''Ορθογραφικός έλεγχος'' on the second blue screen on the right its the Spell check, as you can see its enable but doesn't working.

  • @gprock So you can enable the spell checker but it doesn't work?

  • @leocg yes i can enable the spell checker but it doesn't work. And i can't add any launguage.

  • Personally I also have a problem with the spell check, everything is selected correctly in the settings however, but nothing works, the errors are not displayed and underlined as in Opera "Traditional" (I am forced to jump from the one to another) ... What a shame, it was almost a 10/10🙁
    Would someone have a solution? (or someone else the same problem? it would be nice for the developer to look into this recurring spell Check bugs)🙏
    Thank you in advance, for your solutions

  • Okay, I've tried here and it doesn't seem to be working.

  • Opera GX it's for me almost a 10/10, and its a new project, its normal to have some bugs. But i hope to fix them because spell ckeck is a must for me and i can't have my primary browser whitout spell check.

  • I can confirm that I have this issue as well.

    Using German version and have German, German (Switzerland) and English set as languages.

    No underlines.

  • @gprock I'm having exacly the same problem. I was using the normal opera before with 3 dictionaries for spell checking. Looks like when I merged over to the GX the dictionaries partialy stayed, but aren't working and aren't listed in the settings under languages. I can choose them by RMB on text areas, but the missspelled words aren't getting marked.

    Adding or removing them isn't possible from the Opera itself, because the "installed" ones aren't listed and when clicking on add new nothing happens.

  • @sinoishere Exactly that my friend, i couldn't say it better. i hope with next update they will fix it

  • I'm having exacly the same problem 😞

  • Finally!! With the 60.0.3255.51199 Update, this is fixed!🎉
    A huge 'Thank you' to developers 🙏👍

  • Still not working for me

  • @gprock said in Opera GX Spell Check Problem:

    Still not working for me

    😦 Really? I mean for the English (US) and for French, this looks work now...strange🤔

  • @gprock Amazing! Now everything is working 🙂

  • @gprock I have just tried the Russian and Serbian language (according to copied / pasted on IG) and they also work ... have you tried uninstalled and reinstalled your version if the update did not give results ? ... (I guess it will be yes, but it's strange that it works from one user and not from another reason of my test and my question a little stupid 😅)

  • @traumartistiquement-votre I did the update and nothing, then i re-install it and still nothing, then i uninstall it and install it again and nothing, but for some reason, i did it one more time, and the second time it worked. I m so glad, and i'll do the Opera GX my main browser. 👍🏻

  • For me the highlighting works again therefore I can auto correct the words again, but the installed languages still don't appear in the "Language" options and any new can't be added, because the add new button still isn't working.

  • Hey guys I just fixed it completely for me. I changed the order and the default keyboard language in windows and all the languages appeared in the opera options again. Nice to have them working again!

    Oh, but the add new button still isn't working... 😞

    And after restarting Opera the languages are gone again from the options list.