Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera saved all Captcha text, and it's very annoying for me

  • sorry for the title that might not be good, so just go straight to the problem.
    every time I input captcha Opera always save it, this feature is good when I input my email because it saved my time, but it will be very annoying when Opera also stores the Captcha code every time we fill it, I hope next time Opera not save captcha code, just only email or something important, thank you
    I'm using latest Opera 60.0.3255.151

    I include image, first image when I want to enter captcha code
    1a.jpg

    second image when my cursor highlighted the box, suddenly all my previous captcha code appears, it's very annoying because it covers the captcha code
    1b.jpg

  • You could goto opera://settings/addresses clear any entries you don't want and then turn off autofill. However, sometimes the entries you want to delete are not listed. In that case, you have to also delete all entries by going to opera://settings/clearBrowserData, switching to advanced, setting time range to "All time", unchecking everything but "autofill form data" and clearing history. If that doesn't do the trick, you might also have to close down Opera and delete the "Web Data" file in Opera's profile folder (see opera://about for the path).

    You can try shift + del on entries in the drop-down to see if that gets rid of them (till Opera adds another one).

    The downside though of course is that you cripple Opera with saving other entries like your email address. Not sure there's a way to fix the issue currently in Opera. Maybe there's an extension that adds autocomplete="off" to captchas. Not sure.

  • @burnout426 thank you for the reply but it looks like it's very complex and seems to be for expert users.
    I have never had this problem before, I think the old version of Opera (I forgot what version) is better when there is an option to delete the autofill history individually but the developer seems to delete that feature now

Log in to reply