Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Why Is Talkgeria.com Not Displaying On Mobile Operamini

  • @talkgeria Then it seems that Opera for Android and Opera Mini are being blocked. Try checking again if even with data savings and adblocker disabled the site still doesn't load and, if it's the case, I guess that the block would be the best shot.

  • @leocg I tried it all.. The issues still persist..
    Really appreciate your quick response..

  • @talkgeria It doesn't seem to be an Opera issue but you can try filling a bug report, so someone from Opera can check if they can do something.

  • How Do i go about that sir?
    Really appreciate your response.

  • @talkgeria Sorry, I ran out of ideas. Try checking your logs.

  • @leocg Ok!

  • Hi @talkgeria

    I have investigated your issue a little on several devices and while your website works properly both in High data savings mode and with data savings turned off, there is an issue when data savings is set to Extreme - thus there may be an issue, too, when data savings is set to Automatic.

    Regarding Extreme data savings mode: it seems that our requests are rejected by Cloudflare, whose servers your domain points to. This means there isn't much we can do on our side except contacting CloudFlare, which I am about to try.

    What's interesting, the issue is gone if I manually change browser's user agent and as far as I know, Cloudflare offers configurable blocking per user agent. Most probably it is either this or Cloudflare defaults, but it's not common for us to have such issues with other Cloudflare-protected websites.

    Therefore:

    1. Since I am unsure whether you've tried accessing your site using different data savings mode before, could you confirm that the two modes mentioned in the beginning (ie. High data savings and Data savings off) work for you? These can be set in Opera Mini menu.
    2. I would suggest you to take action, too, and ask your hosting service provider whether he uses Cloudflare to block specific User Agents, especially those including "Opera Mini" or "Presto".`

    Regards
    Kacper

  • @kaniolek Wow! Thanks for helping me out; I really appreciate your kindness and support. I have tried what you asked me to do.

    I set the modes to High data savings and Data savings off which works perfectly. But the extreme and Automatic ain't still working..

    Here was the response i got from Namecheap(my hosting);
    " We don't set up Cloudflare by default, as our customer can use any third-party nameservers they want with our hosting."

    I'm sorry for the late response..

    Thanks.

  • Hi @talkgeria

    Hm, strange. It may sound like a wild idea but... Since Namecheap's response sounds like it must have been you - or one of your coworkers - that set up CloudFlare: could you check once again if it is not your own safety-related settings that disallow Opera Mini proxy user agent? Don't get me wrong, but think of it: your domain clearly points to CloudFlare, your site is hidden beneath it and at the same time it's up to the customer of Namecheap to set up third-party nameservers.

    Regards
    Kacper

  • @kaniolek Ok... What do i do now?
    I dont get this "safety-related settings" (Or let me say how o i go about it)

    I need my blog to start working perfectly on your platform please!

    Thanks.

  • @talkgeria You probably will need to host the site somewhere else or ask your technical staff to change the name server.

  • @leocg Yea. i can change the NS. should i?

    Where should the NS be pointing to?

  • @talkgeria You need to contact your host and your site technical staff, only they can give you the answers.

Log in to reply