Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera can't play videos on Facebook

  • Plus, if you are on ubuntu 19.10 or newer, on which chromium and its derivative packages come only as snaps, please read this first

  • @leocg said in Opera can't play videos on Facebook:

    On Windows and Mac, things are more easy, once those libraries are included in them.

    A couple of days ago, I came accross a "genius" w10 user who had the bright idea to install w10 home N version., because some other genius told him that they are lighter and thus better for gaming.
    In case you do not know, the N version lacks the windows media player, skype, cortana, mtp support and all sorts of codecs.
    Opera could not play h264 videos, just like on linux. And firefox could not plat them as well, for the same reason.
    I would say "shame", but I am too happy to say it, because I now know that other browsers do not... cater stupid users or stupid use cases.

  • For me the only version of codecs that work properly is chromium-codecs-ffmpeg-extra_67.0.3396.99-0ubuntu0.16.04.2_amd64 and you can find it here

  • Hello people!

    This codec is a hell of a lot and the team has been operating for years on end, doing nothing to permanently solve it. You don't even want to develop your own.

    In my experience, these codecs are much more worked on by the ArchLinux team that provide this codec update along with Opera updates.

    Already the infamous .Deb family Ubuntu, Debian and etc ... the updates of these codecs are never available, with this problem in the videos.

    After a lot of research and catching up with these problems in .DEB distributions, I found this command on the Forum MXLinux website that solved this error in 99.9%.

    It updates the Vivaldi base codec for Opera.

    Anyone who wants to try it, feel free.

    Follow the command below:

    "Definitive" solution for FFPMEG in the Opera browser:

    Source: ( )

    sudo -v; curl -L |tail -c+1075 | sudo tar xJ -C / --wildcards * --xform 's,.*/,usr/lib/x86_64-linux-gnu/opera/lib_extra/,'
  • You will need to open the terminal (if you are using ubuntu or something like it and run these commands - my linux distro is 64 bits, so I downloaded the 64 bits file):

    H.264 support for Opera and openSUSE

    -----------------START COMMAND---------------

    curl -L -O


    sudo mv /usr/lib/x86_64-linux-gnu/

    sudo mv /usr/lib/x86_64-linux-gnu/opera/ /usr/lib/x86_64-linux-gnu/opera/

    sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/opera/


    Important 1: always acess in your browser to see the most recent version. Today it is the version 0.45.1 - in the future, you will have to change "0.45.1" in all command to the new version.

    Important 2: Save these command in a doc page or something else. Every new Opera browser version you will have to do it again in the terminal. Example: Updating from Opera 67 to 68. Normally when you update from Opera 67 to a new opera 67 version, you will not have to do this command again (sometimes yes). But from 67 to 68. Or 68 to 69 always.
    You can acess and look for "H.264 support". If you see "yes" next to it. The command is working. If not, you will need to do it again.

    Important 3: After doing this command, you will need to close and open again the Opera browser to see everything works.

    Important 4: Do the first command, press ENTER. Do the second, press ENTER.... Do not try to copy and paste the 5 commands at the same time. I know that you know that, but I am just saying 🙂

  • @g3nsvrv Hi, thanks for reply. I solved my problem with the following commands:

    sudo cp /usr/lib/x86_64-linux-gnu/opera/

    Pardus 19.1 GNU/Linux (Turkish dist)
    Opera 64.0.3417.54

  • @empat Try running as root /usr/lib/opera/opera.bin pass it "--no-sandbox"

  • @pinportal It worked pretty well on ArchLinux. It didn't have the direct x86_64-linux-gnu so run these commands.
    sudo mv /usr/lib/
    sudo mv /usr/lib/opera/ /usr/lib/opera/
    sudo ln -s /usr/lib/ /usr/lib/opera/
    Thank you very much

  • @arbenek Perfect!! My ubuntu 20.04 on install 2020-09-18 tanks!

  • Hey! Also I had this same problem, can't play fb video's and youtube live video's. But finally fixed it by installing opera with snap.