Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera cannot play certain videos on latest version of Kubuntu 19.10

  • Hi,
    I think this may not be a strictly Opera issue but nevertheless, Opera is one of the browsers getting affected.

    I did a fresh install of Kubuntu 19.10 yesterday. During installation, I did check the option to install thrid-party codecs. After the OS was up & running, I installed latest version of Opera as well as Vivaldi browsers.

    In both browsers, I am not able to play online video content which requires Flash I guess. Videos on Twitter don't work as wll as vidoes on most news websites.

    I decided to check availability of and copy the same to Opera's installation directory. Funny thing, I cannot find "chromium-browser" folder in usr/lib/.

    I installed Chromium browser from the default Software Store/Package manager but it installed the snap version of it. After installation I still can't see a folder "chromium-browser" in usr/lib/

    Further, I installed "Transitional package - chromium-codecs-ffmpeg -> chromium-ffmpeg snap" codecs separately but it seems to have made no difference.

    Bottom line, I still cannot play flash videos on both Opera & Vivaldi browsers.

    I guess I can use Chromium browser temporarily till the problem is fixed but I prefer to use Opera.

    I opened a new thread to help out other Opera/Vivaldi Ubuntu 19.10 flavors users who may in the same boat as I am. Further, I will try to post this on Kubuntu forums as well, but hoping some one can provide resolution ASAP.


  • So I found out that Chromium as well as the ffmpeg codes are installed in
    /snap/ folder.

    The ffmpeg is in /snap/chromium-ffmpeg/current/

    But in this current folder, there are multiple sub-folders with numbers like "chromium-ffmpeg-91124", "chromium-ffmpeg-91696" etc. If I want to overwrite the file in Opera's installation directory to test out if that resolves the issue, any idea from which folder under current I should pick?

    Further, I'd request Opera Devs to look in to this issue in future releases i.e. Ubuntu wants to move to snap versions of Chromium & the codecs and Opera needs to work with the above.

  • Let me tell you the bad news, in case you did not hear them from anyone else.
    Starting with 19.10, ubuntu will ship chromium (and its "relatives", i.e. chfomium ffmpeg codecs) only as snaps. The reasons are listed here

    This means that now that there is no chromium ffmpeg codecs deb package, video supoort for formats like h264 will remain broken on opera for ubuntu users as well. So, for the first time, may I suggest you install the snap version of opera? I am against snaps in general, but if that solves your problem, so be it.

  • Hi,
    Can those installations be accessed, then pointing with a SymbLink?

    The few I've read about Snaps, seems to be "closed", but can't test by myself yet.

    Thank you.

  • No idea about the symlink. The whole snap idea is very restricting, because it essentialy runs apps in a sandboxed enviroment.

    What do you mean with "closed" in:

    "The few I've read about Snaps, seems to be "closed"?

  • I meant Sandboxed, but since had installed Mint x86 and Opera Snaps are just x64, didn't check it yet.

    Because of this Sandbox somewhere read or misunderstood, that the files can't be accessible.

    If I'm wrong, then a Symbolic Link pointing to the Codecs folder would work.

    I still have to figure out about install x64 or skip Opera, but I would face the same problems / solutions on Vivaldi - despite they don't have Snaps currently -.

  • @jimunderscorep I've already installed snap versions of both Chromium browser and ffmpeg codecs as well. But Opera is not able to play certain videos.

    I hope the developers have a plan on "working" with snap versions of ffmpeg codecs for Ubuntu 19.10 & later...

  • Open and post a screenshot of what it says as supported under the video section.

  • f258f62e-f58a-4ed6-a0ab-5c4f2b189341-image.png

  • As it seems, the opera snap does not find the chromium ffmpeg codecs snap, thus the lack of h264 support.
    Since I do not use snaps, take a moment to read this thread and find out what is wrong via the snap interfaces and the snap connect command.

  • @jimunderscorep I don't think my Opera installation version is snap. I installed Opera through the regular .deb file.

    How do I find if my Opera version is snap?

    Will go through the thread and see if I can figure out. But honestly, I may just wait till the devs come up with a solution from their end. If they don't, then I will probably use Opera for its VPN service and switch over to Chromium for other browsing needs.

  • Hi @burner2000, in that case (regular .deb), you can try to install the chromium-codecs-ffmpeg-extra_77.0.3865.120 using this link, or if you want, you can add the repo: deb disco main , since there's no pkgs for Eoan (19.10), and install the package using apt.

    Regarding the snap version of the current Opera stable. It should work, if you really install both: the Opera and the lib from the snap, tought it has connection to old version of the lib:

    snap connections opera | grep ffmpeg
    content[chromium-ffmpeg-93464]  opera:chromium-ffmpeg-93464     chromium-ffmpeg:chromium-ffmpeg-93464

    Which means, the version of Chromium 73.0.3683.75.

  • @burner2000 Regarding:

    How do I find if my Opera version is snap?
    Go to opera:about, scroll down to "Paths", and if the paths contains "snap" word, it's the snap version.

  • Guys, thanks for the replies. I will try installing the snap version later on and see if it resolves the issue.

  • I installed the snap version of Opera (after purging the existing installed one) and H.264 videos seem to be working again.

    However, Kubuntu denies me access when I am trying to upload files other than in Home location. Permission is denied when trying to access any of my other mounted drives. Tried to look up the issue online and it seems like a feature of snap. People had suggested work arounds but it sounded complicated.

    But the above is something I can live with.

    Thanks again for the replies & help guys.

  • @burner2000 said in Opera cannot play certain videos on latest version of Kubuntu 19.10:

    Kubuntu denies me access when I am trying to upload files other than in Home location. Permission is denied when trying to access any of my other mounted drives. Tried to look up the issue online and it seems like a feature of snap.

    Snap apps can not access everything on the filesystem. They have permissions etc. Look up on how to set snap permissions.

    Since you are the first 19.10 user with the codecs issue here, I would like to thank you for taking the time to test and verify all that. Conclusion: if you are on ubuntu 19.10 and later, the opera snap + the chromium ffmpeg codecs snap is the only way to have an opera that supports all video formats. And the ones to blame for that situation are the ubuntu devs that have stopped providing deb versions of chromium and its "family" of packages.
    This also makes the faq stuff on the post on my signature obsolete.

    p.s. I am bookmarking your thread for future reference, e.g. in 6 months that everyone will install or upgrade to 20.04, the forum will be flooded with issues like yours.

  • @jimunderscorep Happy to help.

    I will try to look up on setting snap permissions.

  • Hello,

    I've created an article addressing the issues created by the newest version of Ubuntu 19.10. Please follow the link