Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Spotify links don't open in the app

  • Hi,

    When someone shares a Spotify link and I open it, it opens in Opera with an error message, instead of opening the Spotify app that I already have installed.
    How could I force opening a Spotify share link in the app instead of in Opera browser?
    Eg. of a sharing link : https://open.spotify.com/track/1CCgbiLZ4Gy0OzNayiFSRT?si=0OYrv9qAQTi234B_ArvJfQ

    Version of Android: 9

    Phone model and manufacturer: Huawei P20

    Your version of Opera for Android: 49.2.2361.134.358

    If the problem is with a page, a link to it:
    https://open.spotify.com/track/1CCgbiLZ4Gy0OzNayiFSRT?si=0OYrv9qAQTi234B_ArvJfQ

    If ad-blocker is enabled or not: tried with and without

    If data savings is enabled or not: no

    A screen-shot of the problem if it's related to something not showing as should

    A description of the problem, including as much as information as possible: Spotify links load in Opera instead of in Spotify app

    Steps to (try to) reproduce the issue: open Spotify sharing link

    Expected behavior and actual one: open Spotify sharing links in Spotify app

    A screen-shot of the problem if it's related to something not showing as should
    0_1548451408451_Screenshot_20190125_220134_com.opera.browser.png

    Sorry French interface but it basically says "playing deactivated, Spotify won't work if you block the protected content, if your browser is not compatible, or if you are using the incognito mode. Adjust your browser settings or download our free mobile app." Button says: Download app.

    Thanks a lot for your help!!

  • Ok, I managed to figure out what happened. The toggle has indeed been removed, but it's no longer needed. When in the web player, just click on the device switcher (the icon at the bottom, looks the same as in the desktop app) and choose your computer. The preference will stick until explicitly switched again.

  • Hi anitakate,

    Thanks for your feedback ☺

    Do you mean I need to switch to the desktop view of the page? If so, I've tried that, but I still have the same error 😔
    Or were you referring to another option?

    Thanls!

  • Hello,
    Does someone have an idea 🙂 ?
    Thanks so much

Log in to reply