Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera mail client duplicates sent messages

  • Hello,
    I am still using the Opera 12 browser's in-built e-mail client. Since the last couple of weeks I have noticed that it duplicates any email sent from the browser. This does not occurr if I send from Ms Outlook or my smartphone, so I guess it must be something with the browser. During this time span:

    • our server admins requried all users to change password (I relate this as some google search results for other IMAP clients suggested this might be due to IMAP synchronization)
    • I have temporarily installed and then removed Opera Mail (the separate product)

    Thanks fro any help

  • (For others, this is a university MS Exchange server with IMAP turned on.)

    Download https://ftp.opera.com/pub/opera/win/1218/int/Opera_1218_int_Setup.exe, launch the installer, click "options", set "install path" to a folder on your desktop, set "install for" to standalone installation and install. Set up the IMAP account in it, but don't enter your username and password in the new account wizard. After the account is set up, go into its properties and set "do not make messages available offline" (to avoid ever storing the messages on your drive for this test version) on the incoming tab. Do not set "low bandwidth mode" or "do not download attachments". Close out of the properties and then check/send and enter you username and password.

    Once the headers for your messages sync, go into the account's settings and make sure the IMAP sent folder is set to the same sent folder that's used by the webmail interface (if there is one).

    Then test things out to see if you still have the problem. Maybe your regular Opera is corrupted again.

    If things are still messed up with duplicates, we can try some things in this test Opera instead of your regular one for now.

    From chat, it looks likes you're setting both a local copy of the sent message that Opera places in "All Messages/Sent" and a server copy. Why there's not only single copy (when you have an IMAP sent folder set), I'm not sure unless the SMTP server is creating its own copy and placing it in the sent folder on the server and Opera's copy that it tries to create on the server gets blocked. In this case, you'd really want the copy the server generates and not Opera's local copy. But, besides hiding it with a label or unchecking "show duplicates", I'm not sure what can be done.

    I guess one thing to test is to unset an IMAP sent folder in Opera and send a message. Then, look in another IMAP client or on the server via webmail and see if the sent message still ends up there. If so, the server's probably producing the sent message.

    You might also turn on logging with an IMAP sent folder set and see what happens in the log when Opera send the "out" command to append the sent message to the IMAP sent folder. Maybe the server denies it or something.

    @kalder said in Opera mail client duplicates sent messages:

    I have temporarily installed and then removed Opera Mail (the separate product)

    Did you test with it also?

  • See my post in this other thread. I believe the issue is the same as yours.

  • Hello and thanks (I think the other thread was me, sorry for duplicating I was unsure whether it was accepted.
    I have now installed both Opera mail and Opera standalone. I am making tests with both (frequent crashes when contacting server). Results:

    • If I use Opera Mail/standalone with the default "Sent Folder" in Tools/Mail & Chat accounts/Account Properties/IMAP, I do get duplicates in the All messages/sent folder. Duplicates are also created in the original Opera 12, Outlook and smartphone sent folders.

    • If in Opera Mail/standalone I remove the "Sent Folder" the duplicates go away. However: sent msgs are not stored in the "Sent messages" IMAP folder but only in All Messages/Sent folder (but still appear in Outlook/smartphone). So if I send a message with Outlook and/or smartphone the sent message will not show in Opera with other sent messages

    • ideally I would rather have Opera not to store any copy in the All Messages/Sent folder but just save in the IMAP/Sent Messages folder, like Outlook and smartphone.

    Why unchecking "show duplicates" is not an option: the duplicate message is way larger than the original (between x20 and x30 in size, e.g. a text-only, 2.6kb, sent message gets a duplicate of 86kb. Just imagine if I send an attachment) and my mailbox is entirely copied locally and the Opera/Mail folder currently amounts to 47+ Gb. I would not really have it swell at a significantly faster pace.

    If needed I can copy the original and duplicate messages' headers

    thanks a lot

  • @kalder said in Opera mail client duplicates sent messages:

    If I use Opera Mail/standalone with the default "Sent Folder" in Tools/Mail & Chat accounts/Account Properties/IMAP, I do get duplicates in the All messages/sent folder. Duplicates are also created in the original Opera 12, Outlook and smartphone sent folders.

    Yep.

    @kalder said in Opera mail client duplicates sent messages:

    If in Opera Mail/standalone I remove the "Sent Folder" the duplicates go away. However: sent msgs are not stored in the "Sent messages" IMAP folder but only in All Messages/Sent folder (but still appear in Outlook/smartphone). So if I send a message with Outlook and/or smartphone the sent message will not show in Opera with other sent messages

    When the duplicate doesn't show in the IMAP sent folder, under the you@example.com IMAP folder access point in Opera's Mail panel, select another IMAP folder and then select "Sent" again. And, check/send again. Does the duplicate then show up again despite an IMAP folder not being set? Restart Opera a few times and check/send etc. Then, try a few more send tests. Then, look in the incomingN.txt file in the mail folder where N is the number for the account as seen in accounts.ini. Do you see Sent= being set back to "Sent"? You can check on the IMAP tab in the account's properties because the drop-down will default to "Sent" instead of blank even if it's set to blank in the file.

    Anyway, what I'm seeing in this situation is that you might not get a duplicate at first with a an IMAP sent folder not set. But, Opera will revert it on you. If it doesn't then that is indeed nice and it's working right. But, I myself still get a copy in the IMAP sent folder. The copy is the one the exchange server creates (the bigger one). Whether you get that copy or not, there's no way to change the behavior for when you unset an IMAP sent folder. But, that copy might just be treated as a normal received message that's in the IMAP sent folder (when you don't have an IMAP sent folder set).

    One that you can try for the IMAP sent folder and all messages/sent is to click the "settings for this view" button on the message list toolbar and choose to override the global settings to turn off threading and then uncheck "show sent" and recheck it. There's a bug with threading and "show sent" for sent messages that never received a reply from the recipient. They won't show.

    @kalder said in Opera mail client duplicates sent messages:

    ideally I would rather have Opera not to store any copy in the All Messages/Sent folder but just save in the IMAP/Sent Messages folder, like Outlook and smartphone.

    Well, one thing you can do is drag the IMAP folder access point in the mail panel to the top and ignore all of Opera's view like "All Messages", "Mailing Lists" and "attachments" etc. and just use the IMAP folder access point. That way, Opera will work and feel like a traditional IMAP client. You'll still have to do with duplicates, but... at least it'll be nicer.

    @kalder said in Opera mail client duplicates sent messages:

    Why unchecking "show duplicates" is not an option: the duplicate message is way larger than the original (between x20 and x30 in size, e.g. a text-only, 2.6kb, sent message gets a duplicate of 86kb.

    Yeah, the sent copy that the exchange server generates is going to be bigger because of all the extra headers that are added. The server copy won't mulitply the size of the original more than that. Of course, if the sent message has attachments, the attachment will be embedded in both the Opera copy and the server-generated one, which sucks. But, I don't think there's much you can do about it except to unset an IMAP sent folder if it'll stick and then see if you can do that "show sent" work around to see if the server-generated copy will show up iwth that show sent workaround.

  • Little update:

    • even if I remove the "Sent Folder" in Tools/Mail & Chat accounts/Account Properties/IMAP in Opera Mail/standalone after a while (e.g. checking some messages and checking sent messages IMAP folder), the setting goes back and I find again the "sent folder" in Tools/Mail & Chat accounts/Account Properties/IMAP. Thus duplicates start again to appear.
    • I am still puzzled about why only Opera (my 12.x version, Opera Mail and standalone) duplicate sent messages, whereas Outlook and smartphone app do not. And why all this started a few weeks ago...
  • @kalder said in Opera mail client duplicates sent messages:

    I am still puzzled about why only Opera (my 12.x version, Opera Mail and standalone) duplicate sent messages, whereas Outlook and smartphone app do not. And why all this started a few weeks ago...

    Maybe something changed on the server where the server is no longer ignoring Opera's duplicate and it still ignores other clients' duplicates. And or, maybe some other clients don't add a copy of the sent message if it's an exchange server. I'm not sure. I would guess that for Outlook, it's probably not using IMAP to connect and is using the actual exchange protocols etc. For the smartphone app, I guess maybe look in the settings. It may reveal something.

    I'm pretty sure Exchange has been creating its own sent copies for a while, so I doubt that was off and hotmail all of sudden turned it on.