Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera doesn't play some videos

  • Hello everyone,

    I can't play some videos on Opera but they work perfectly fine on other browsers like Chrome or Mozilla Firefox. Not all videos are like this, but there are a lot of them. Those includes for exemple :

    • some Youtube videos
      - some I can't watch all the time (i.e : https://www.youtube.com/watch?v=_ivS9wbKEJI&)
      - some I can't watch just after they have been released ; waiting a couple of
      hours seems to "resolve" the problem (the videos of this guy channel for instance : https://www.youtube.com/channel/UCWizIdwZdmr43zfxlCktmNw)
    • all videos from twitter or facebook
    • twitch streams are not working either
    • Vimeo's and Streamable videos as well
    • gif from Imgur are not working either but gif from gfycat are ok

    Concerning hardware and software :

    • I am running the latest opera version (56.0.3051.36) and I've been trying the beta versions without any success.
    • I am running Windows 10 - 64 bits

    For the hardware i got :

    • Intel I7-2600 cpu @3.40GHz
    • 16Gb of Ram
    • Nvidia GE Force GTX 660

    It has been going on for a few months now ; I don't recall exactly since when. I remember that it was working all fine before. I have been trying to resolve the problem myself but haven't succeeded. I thought it was a h.264 problem but when I go to youtube.com/html5 the website tell me my browser support all format (see screen shot : https://puu.sh/BiZj8/9fac266da3.png). On Html5test.com the website tell me that the Opera does'nt support mp4 (see screen shot : https://puu.sh/BiZl4/a736058912.png). However on https://www.quirksmode.org/html5/tests/video.html the video test they put for H.264/mp4 videos does not work (see screen shot https://puu.sh/BiZpA/06feb37392.png).

    I also tried a few extensions but non resolved the problem. I reported this bug to the opera team late august, but without any improvement since then, I decided to give a try with the forum.

    Fun fact, I got a laptop running Windows 7 64 bits and Opera works just fine on it. All videos playing very well. I can give you the specs if you want.

    So today I decided i had enough of this, so here is my last try to resolve
    this problem. If no solution is found, I will go on another browser and say
    those who asks how Opera is a terrible browser (what a threat, heh ?).

    Thank you for reading and have a good day

  • @tartack

    Have you tried the trick of turning off graphics hardware acceleration in Opera settings? Or updating the video drivers via the Nvidia support site?

  • @tartack said in Opera doesn't play some videos:

    On Html5test.com the website tell me that the Opera does'nt support mp4

    No support for "MPEG-4 ASP support" is fine. Wouldn't worry about that.

    @tartack said in Opera doesn't play some videos:

    However on https://www.quirksmode.org/html5/tests/video.html the video test they put for H.264/mp4 videos does not work (see screen shot https://puu.sh/BiZpA/06feb37392.png).

    Hmm, works fine here on Opera 56 64-bit on Windows 10. Goto the URL opera://media-internals after trying to play a video. Find the section for the player in question and click it to expand it. Maybe it'll tell you something.

  • @tartack just check n.. didya find a solution..

  • @xpvb48 yes, the support asked me to try that out when i contacted them, didn't work. I also updated the video driver and it didn't work.

    @burnout426 I did what you said and here is what it comes up with : https://puu.sh/BOAYL/ce9e70215f.png
    https://puu.sh/BOAZO/f6014872c6.png

    So it seems to be a decoder or a webmedia player problem. Don't know how to take care of the problem yet. I am going to search if I can find solutions.

    @nvmjustagirl who/what is n.. didya ?

    Sorry to you all for answering this late, the problem being very specific I wasn't expecting an answer after a few days. I should have check the topic more often.

  • @tartack said in Opera doesn't play some videos:

    I am running Windows 10 - 64 bits

    I assume that's Pro or Home and not the N edition of Windows?

  • @tartack could ya answer burnouts queston *pls..

    those Intel I7-2600 cpu @3.40GHz are still pretty hot.. 4 core 8 threads but the K version had Unlocked Multiplier great to over/clock lol

    umm.. does computer also have intel graphics too ?.. along with the Nvidia GE Force GTX 660..

    and is the Windows 10 - 64 bits version 1803 or so..

    if so and ya wanna leave hardware acceleration on in opera settings..

    ya might could try this..

    1.Open Settings.
    2.Click on System.
    3.Click on Display.
    4.Click the Graphics settings link.
    5.Use the "Choose an app to set preference" drop-down menu and select the Universal app option.
    6.Select Opera using the second drop-down menu.
    7.Click the Add button.
    8.Select Opera from the list.
    9.Click the Options button.
    10.Select the High performance option. (If you want lower performance to save battery, then select the "Power saving" option instead.)
    11.Click the Save button.

    Once you've completed the steps, open Opera and it should now be using your PC's discrete graphics card for rendering tasks.

    If you end up experiencing problems, such as high GPU utilization or another performance issue, you can also use these steps to change the Opera graphics preferences to troubleshoot and fix hardware acceleration issues. Bear in mind that rendering issues can also be caused by other problems, such as graphics driver issues. If this is the case, you also want to update your video card driver to resolve any graphics problems.

    Note - To Undo - If you want to revert the changes, or you're experiencing other issues,

    you can always follow the same instructions, but on step No. 5, make sure to click the Remove button for Opera..

  • @tartack said in Opera doesn't play some videos:

    @burnout426 I did what you said and here is what it comes up with : https://puu.sh/BOAYL/ce9e70215f.png
    https://puu.sh/BOAZO/f6014872c6.png

    Could you provide the entire log? That's only part of it.

    Try installing https://support.microsoft.com/en-us/help/4039813/media-feature-pack-for-windows-10-n-october-2017.

    If that doesn't help, close Opera, load up a command prompt and run:

    "C:\Program Files\Opera\launcher.exe" --no-sandbox
    

    Any difference there?

    Any difference if you use --disable-gpu?

  • @burnout426 It's windows 10 enterprise 1803 exactly
    I tried to install the media feature pack for my windows (1803) and it does'nt want to : it says the update is not applicable to your computer.
    I tried 1709 to check and it's the very same.
    I tried your command, it changes nothing. No difference between gpu enable or disable.

    Here is the entire log that I saved and copied in paste bin, I don't know if that's exactly what you want. https://pastebin.com/yUsetFES

    @nvmjustagirl I dont have any Intel graphic, all is handled by the Nvidia Geforce GTX 660
    I tried to do what you said in your steps, but there is a problem at step 6. : Opera does not appear in the second drop-down menu.

  • What security software is installed on your Windows 10 setup? Do you have Sandboxie and or Bitdefender? What antivirus?

    Does the same problem video play in Vivaldi and plain Chromium?

  • @tartack I had the same problem, discussed here: never solved. Thanks for the html5test.com I didn't know. Yep, Opera is quite "lame": 502/555. Jump on Beaker browser when you have problems with Opera. The only problem with Beaker is the lack of bookmarks bar. 520/555 at the test. Plus: DAT peer to peer handling... 😉

  • @tartack you do not the N nor the KN edition of Windows..

    for peeps that do not know..

    Go to Control Panel > Clck Programs and Features > Click Turn Windows Features on or off and look for Media Features.. If it is there, you do not have N or KN..

    if Media Features there and not checked in box.. then check the box..

    Note - Also under Media Features make sure Windows Media Player is checked..

    @tartack said in Opera doesn't play some videos:

    @nvmjustagirl I dont have any Intel graphic, all is handled by the Nvidia Geforce GTX 660
    I tried to do what you said in your steps, but there is a problem at step 6. : Opera does not appear in the second drop-down menu.

    as for step 6 make sure its the reguar install of opera, not sure about Portable Opera..

    here is a Better guide that explains the steps better found here

    scroll down that page to find steps..

    i would select the High performance in step 10..

    hope ya get things work 'n soon.. *hopefully..

  • Try the sample aac file and sample m4a file from http://techslides.com/sample-files-for-development to see if they at least play in Windows with Windows Media Player?