Can't watch youtube videos on Opera 12.16

  • Hello guys!

    For more than a month I can't watch properly almost any video on youtube using Opera browser. The video screen remains black an no playback option is available. I get this error on two different computers. Both have the latest version of flash player and are running on Windows x64. The version of Opera is 12.16
    I don't want to upgrade it to Opera next beacuse it doesn't have some useful features for me.

    Thank you!

  • I've got 12.16 x64, and it works without issue. Did you install the IE version of Flash, or the other version? There's two separate versions available. Alternatively, you might also try removing Flash completely, and reinstalling.

  • Me too I have x64. How do I check if the IE version has flash or not?
    The completely removal of flash player can be simply done from control panel/uninstall?

  • Yes you should be able to remove flash player from 'Programs and Features' (Win7 & 😎 or 'Add and Remove programs' (WinXP). As for checking if you have flash for IE, it should be listed in either of the above two places (depending on Windows version), but have 'ActiveX' written in the name somewhere.

    To download the correct version of flash player for Opera, you have to visit Adobes site using Opera, so that the site will detect you are using Opera and offer the correct version for you to download.

  • So, I have checked and I have installed Adobe Flash Player 13 ActiveX.
    The thing is I tried to download flash player from adobe site and avast antivirus blocked the download.
    I shall try to reinstall the flash player.

  • EDIT

    Bah, I tried to directly link the downloads, but the URLs didn't work afterwards. I guess you'll just have to do as Linuxmint7 stated, and visit Adobe's site directly using Opera (don't forget to uncheck the Google Chrome download).

    http://get.adobe.com/flashplayer/

  • Thank you for your replyes!
    Unfortunately, when trying to download flash player using Opera browser I get this error: "Note: Your antivirus software must allow you to install software." and I don't know which setting I have to change; if I disable avast for a limited period of time, nothing happens.

  • The ActiveX Plugin is for IE, you need the other one.
    I just downloaded it (again) from here: http://get.adobe.com/flashplayer/otherversions/ (choose your OS and the version "for other browsers") and Avast didn't complain, despite having all checks on.

    As you are running O12x64 you should check opera:plugins ( ← type that into the address bar and hit enter) afterwards and disable the non-native 32bit version of the Flash plugin (it is the one with the WOW in its path) so that only the x64 version of Flash works.

  • PS: I forgot to mention that the notice is on the webpage, only meant as a hint and you can safely ignore it, Avast will not complain because it knows the signature of the file.

  • I did as you adviced me and it works fine! I had a version which conained in its path WOW64 and I disabled the other one.

    Many thanks and a bottle of beer to you!

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.