Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera switch audio output on every stream.

  • Around a month ago, opera starts changing audio output on start of every video stream.
    The browser changes the audio output to "build in analog stereo", first in the list but NOT default! Default output remains set to BT headset !!!
    This is super annoying because I want to listen to something during work in BT headphones, but every couple seconds the output switches back to the built-in speakers.
    I do not know what it is caused, but I noticed that when I watch the material on the website and it's interrupted by commercials, new process is spawned with wrong output. I manually change back to the headphones, but at the end of advertisement and resume the main video, it's switch to the speakers again. Sometimes it can change even when switching windows (Alt-Tab).

    Please help, its SUPER annoing.

    P.s. I have frequently updated KDE Neon (ubuntu 18.04 with KDE). Opera 56.0.3051.31

    Below screenshots from audio settings when i try to watch material from polish news page, try play video at the end of article.
    https://www.money.pl/gospodarka/wiadomosci/artykul/nie-tylko-holandia-polacy-sa-wypychani-na,46,0,2417454.html

    But similar problem exists on every video page, eg. Vimeo, it starts with wrong output, I switch back to BT, in autoplay mode every next video play again by "build-in spikers".

    Default options (headset is default) (sorry for polish locales):

    0_1538470584552_audio1.png
    Applications settings:
    0_1538470630619_audio2.png

    Video starts, new process have "Default analog build-in speakers":

    0_1538470662391_audio3.png

    End of ads, switch back to "main" video:

    0_1538470733119_audio4.png

  • Same problem for me. Super annoying and hopefully someone provides a fix.

  • It is so annoying that I changed my browser for multimedia playback, unfortunately it turns out that the Chrome has exactly the same problem. Interestingly, it does not appear in Firefox. But im still not happy, FF is so sloooow and don't have cool PIP plugins 😞

  • I neither use plasma, nor pulseaudio (if this is the case), but what backend do you use for phonon?
    Phonon is the sound server of plasma and it can use vlc or gstreamer as a backend.

  • I have the same problem. Only difference is that for me Opera switches to my USB-connected headset whereas I want it to use my default device: Built-in Audio Analog Stereo, via Line Out.

    Also, if I pause a video, after 10 seconds the opera volume control disappears from the Audio Volume window. When the video is resumed the opera volume control is visible again but now the audio device has changed.

    I run Kubuntu 18.04, as in KDE Plasma 5.12.6 on top of Ubuntu 18.04. Opera version 56.0.3051.36 installed via the downloadable .deb file on opera.com. I previously had Opera installed as a snap and that had the same issue. My Phonon backend is GStreamer 4.9.0.

    I have encountered no other applications with this problem. Firefox doesn't have this problem. I have not tried Chrome.

  • @jimunderscorep said in Opera switch audio output on every stream.:

    I neither use plasma, nor pulseaudio (if this is the case), but what backend do you use for phonon?
    Phonon is the sound server of plasma and it can use vlc or gstreamer as a backend.

    I have installed both gstreamer and vlc, but in config is only "Phonon VLC 0.10.1"

  • There is a setting somewhere in kde's system settings panel that allows you to choose which backend phonon will use.
    Sadly, other than that, I have no solution to your issue for now 😞