Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera cannot access HTTPS sites

  • @mixim-0 said in Opera cannot access HTTPS sites:

    @batbox50 hi. im not speaking nice english, sorry at first. I had encountered a similar problem.

    Opera Developer version running smoothly, but Opera sometimes is giving error for https pages.

    I wonder something. Do you use the static ip service from ISP?

    and also this problem is related Opera's vpn service

  • @mixim-0 Thanks for your interest.

    I'm just a home user with a phone line connection, so nothing fancy provided by ISP. Indeed, according to their forum they don't even provide static IPs.

    Also the VPN is off and always has been.

  • @batbox50 Did you test the Opera Developper? httpss worked smoothly for me.

  • @mixim-0

    Opera Beta - same results
    Opera Developer - same results

  • Chrome and Opera use the system's network stack. So, it's probably an issue with a setting in Windows. Firefox uses its own network stack, so that could explain why it doesn't affect Firefox.

    Did you try in Edge and IE to see if they behave the same way?

    What if you remove Opera and others from Zone Alarm, try to connect to the net with them so that Zone Alarm prompts you again where you choose to add them back?

    It's been years since I used Zone Alarm, but if it has any type of features (besides the main firewall part) that scan web pages, turn those features off to see if it makes a difference.

    Are the Date, Time, Time Zone and Daylight Savings settings correct?

    In "internet options" in Windows settings, on the "connection" tab, click "LAN settings". Make sure no proxy is selected. Turn of automatic detection too.

    In Windows under "Settings -> Network and Internet -> the connection type you're using -> change adapter options", right-click on the adapter you're using and goto "properties". Check the IP4 and 6 properties to make sure "obtain automatically" is set for both IP address and DNS.

    Open "C:\Windows\System32\drivers\etc\hosts" in a text editor. What's it look like? Normally all lines will be commented out by #. There shouldn't be any active entries in there unless Zone Alarm or something added them.

  • @burnout426 Thankyou for your detailed suggestions. Results follow:

    Internet Explorer - Displays successfully - Can’t reach this page, Make sure the web address is correct - Can’t reach this page, Make sure the web address is correct

    Edge - Displays successfully - Can’t connect securely to this page
    This might be because the site uses outdated or unsafe TLS security settings. If this keeps happening, try contacting the website’s owner. - Can’t connect securely to this page
    This might be because the site uses outdated or unsafe TLS security settings. If this keeps happening, try contacting the website’s owner.

    Removed from ZoneAlarm, but it puts it back automatically when Opera is restarted, without asking me. Getting it from a cache of previously recognised programs perhaps? I am sure that I have successfully removed it before retrying, as there were many entries removed and only the current one comes back.

    Only Firewall is active in ZoneAlarm.

    Date etc. settings all correct.

    No proxy, auto detect off.

    IP4 & 6 both "obtain automatically" for IP and DNS

    No active entries in /etc/hosts file.

  • @batbox50 BTW, my Internet Options include TLS 1.0 - 1.2 inclusive.

  • @batbox50 is your pc date/time correct? TLS errors can be if old date is set

  • @mixim-0 Yes date, time and zone all correct.

  • In Opera, goto for example and after it gives you the error page, hit ctrl + shift + i and go to the security tab. Maybe the overview there will reveal the issue.

    You could scan your computer with Malwarebytes. You'll probably have to use Firefox to download it though. Maybe something is trying to do a man in the middle on your secure connections.

  • @batbox50 may it be blocking by Zone Alarm. You should review its settings carefully.

    a similar problem here Secure Connection Failed Problem

  • @burnout426 Interesting idea.

    Security overview says "This page is not secure" but then shows certificate as valid and all resources being served securely - somewhat contradictory.

  • @mixim-0 Smart idea! Not Zone Alarm, though, but Bitdefender. It's the Online Threat Prevention > Encrypted web scan. Now I've turned that off I can access the pages again. I think this must be something new they put into the last release - Bitdefender Antivirus Plus 2019 Build which was updated on my pc 21/09/2018.

    Of course, now Bitdefender is maoning at me, but I'll have to take that up with them.

    Thanks for all who made suggestions - I've learned a lot about all sorts of things in this, albeit painful, process.

  • @batbox50 You are probably wondering why I didn't think of checking Bitdefender before.

    Of course, I did check its Notifications to see if it was objecting to any activity - it never showed any warning or information that it had taken action against any threat!

  • @batbox50 Interesting. Another user just had issue with Bitdefender messing things up.