Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Widevine and Opera

  • @mpvrisavant It worked for me in Opera 65.0.3467.48. Thank for sharing

  • @paulkastel
    I performed some updates of software and of operating system and Opera lost DRM support - again.

    (This is joke from creators of Opera, that after all this time it works on macOS and Windows and Linux version of their product is not supported as well).

    But - good news is that I performed same steps from my instruction but in step 5 I used newer version of codecs: 0.42.4-linux-x64.zip, and Opera ver. 65.0.3467.48 plays Spotify Web again.

  • As mentioned above the problem is the predefined path of widevine plugin which points to an address which is not valid anymore.

    1. Install google chrome or download the libwidevinecdm.so
    2. edit /usr/lib/x86_64-linux-gnu/opera/resources/widevine_config.json and give it the address of the libwidevinecdm.so
      in my case it was
      /opt/google/chrome/WidevineCdm/_platform_specific/linux_x64/libwidevinecdm.so
    3. restart the opera and it will work fine.
      I am using Opera 65 on Linux.
  • @igitqara this works. remember to clear browser cache too!

  • @mpvrisavant Rally appreciate it!!! This has worked for me😁 😁

  • Like @paulkastel wrote before "I performed some updates of software and of operating system and Opera lost DRM support - again." I have AGAIN the same situation, but this time above solution just not work.
    I have new ffmpeg, libwidevinecmd, corrected (again !!!) widevine_config, and still no DRM, no Netflix, no Spotify.
    This is not annoying anymore, this is a joke. Every #fword update is the same situation.

    Any suggestions besides switching to Chrome?

    This time Opera 66.0.3515.44 on Kubunu Linux 19.10

  • P.S. (Can't edit now) Chrome on the same libs works fine and shows in Components - Widevine 4.10.1610.0, where Opera shows 0.0.0.0

  • Great. It is broken after Opera 66 update. Chrome version is 79 right now. I have no problem with Youtube videos but I cannot access Spotify.

    I learned last version from this link: https://dl.google.com/widevine-cdm/versions.txt
    Then downloaded last Widewine library using this link: https://dl.google.com/widevine-cdm/4.10.1582.2-linux-x64.zip
    (This is what afore-mentioned script does)

    All settings are correct but Opera doesn't play DRM content. I have updated this file too: /opt/google/chrome/libwidevinecdm.so

    # /usr/lib/x86_64-linux-gnu/opera/resources/widevine_config.json
    [
       {
          "preload" : "/opt/google/chrome/libwidevinecdm.so"
       },
       {
          "preload" : "/opt/google/chrome-beta/libwidevinecdm.so"
       },
       {
          "preload" : "/opt/google/chrome-unstable/libwidevinecdm.so"
       }
    ]
    
  • @parasit I also confirm that after upgrading to Opera 66 the above mentioned solution is not working anymore. I have tried different versions of libwidevincdm but none worked. I have switched to Brave, since I had enough of this frustrating issue. All other chrome-based browsers such as Vivaldi and Brave already fixed this stupid problem by simply delivering the widevine with the browser.

  • According to Vivaldi developers there needs to be a manifest.json file for Chromium 79+. I tried to use that manifest file for Opera but I couldn't make it work.

    If you want to try yourself here that file: (Make sure you have right version of Widevine)

    {
        "arch": "x64",
        "description": "Widevine Content Decryption Module",
        "manifest_version": 2,
        "name": "WidevineCdm",
        "os": "linux",
        "version": "4.10.1582.1",
        "x-cdm-codecs": "vp8,vp9.0,avc1,av01",
        "x-cdm-host-versions": "10",
        "x-cdm-interface-versions": "10",
        "x-cdm-module-versions": "4",
        "x-cdm-persistent-license-support": false
    }
    
  • I have the same problem. Debian testing system.

    Since Opera 66 and above, Widevine support does not work.

    I reported the problem to them several times, but no response.

    Can the creators of Opera explain why in their browser they can not add built-in libffmpeg and widevine in the browser? Somehow on Windows you do not need to install Google Chrome to have Widevine.

    Now there is also a problem with the libffmpeg.so file, because before it was enough to install the appropriate package for Chromium. Now this file is stapled in the browser.

    Using Opera on Linux has become very limited and problematic.

    @maydin95 , where to upload this file?

  • @macfly1987 I read it from a Vivaldi developer in Vivaldi forum, he said there needs to be a manifest file but I have no what to do.

  • @maydin95 Hello and sorry for the delay.. My hard drive broke and I did not had any linux installed to test.

    It seems to me that the Opera Developers don't have the intention to support widevine in Opera linux for some reason.

    I did many changes and tests.
    modified the widevine.config.json from: /opt/google/chrome/libwidevinecdm.so to /opt/google/chrome/WidevineCdm/_platform_specific/linux_x64/libwidevinecdm.so (and subsecuent) since the latest chrome changed the libwidevinecdm.so location.

    I downloaded the latest libffmpeg.so and made sure H.264 support was enabled (Test it on: https://html5test.com/).

    I created a soft link using: ln -s /opt/google/chrome/WidevineCdm/_platform_specific/linux_x64/libwidevinecdm.so /opt/google/chrome/ to be able to keep the original widevine_config.json file from opera (This worked great before so I didn't have to modify it everytime opera got updated.

    Nothing works... 😞

    In conclusion.. Opera doesn't work with widevine anymore (As of today), I hope the Opera Developers would explain why, but probably they don't care about linux users anymore.

    I even installed Opera for Windows and noticed that there is a folder named WidevineCdm located at: C:\Users\userprofile\AppData\Roaming\Opera Software\Opera Stable\WidevineCdm\ that seems to be google Chrome's.. so did the same on the linux side and did many tests, I even changed the manifest.json with no success.

    I noticed that in the manifest.json file the widevine library for linux is not defined so I did it myself.. Still it doesn't work.

    I have to say that I love Opera but since it doesn't work with widevine anymore and unable to watch netflix and listen to spotify I will remove it from my system.

    I'll keep you posted just in case it works for me.

    Regards
    Ezequiel Partida (ZekeMX)

  • @maydin95 said in Widevine and Opera:

    @macfly1987 I read it from a Vivaldi developer in Vivaldi forum, he said there needs to be a manifest file but I have no what to do.

    You can try asking Ruari. He deals with Linux for Vivaldi and has written all those libffmpeg and widewine scripts for Vivaldi. He used to work for Opera too. If it's something that can be fixed outside Opera with the manifest thing, he probably knows how to do it.

  • @zekemx said in Widevine and Opera:

    In conclusion.. Opera doesn't work with widevine anymore (As of today), I hope the Opera Developers would explain why, but probably they don't care about linux users anymore.

    @ zekemx:- That's it in a nutshell. I read somewhere, not many days ago, that Opera has been bought out by one of the 'big boys'. Expect many more annoying changes like this over the next few releases; these people have made it crystal-clear that they are only going to support Windows exclusively.....because that's where the money is.

    Everybody else can go whistle. So; it looks like I, too, will be returning to Chrome again.

    Bloody annoying.....but at least Big Brother doesn't give you quite this many hoops to jump through for an overall 'experience'. And everything does work, with relatively little 'pain'.

    Mike. 😠

  • Hi guys, I have some good news ;-)
    I just checked it, and the problem looks to be solved in the latest developer version
    (68.0.3602.0 - "DNA-84335 [Linux] Widevine is not working due to changed path of libwidevinecdm.so"),
    when you provide proper path to Widevine's folder in the "widevine_config.json" file, for example "/usr/lib/chromium-browser/WidevineCdm".

  • Widewine works again in developer version (Version:68.0.3602.0). It seems that they have changed the format of widevine_config.json and now instead of poinitng to the library file, the addresses point to the WidevineCdm directory containing manifest.json file and _platform_specific directory. This would be by default /opt/google/chrome/WidevineCdm

  • The setup I did for Opera Stable (66) for libffmpeg and Widevine on Linux Mint 19.3 XFCE is this:

    • Install Google Chrome and Opera.

    • Create "/usr/lib/x86_64-linux-gnu/opera/lib_extra"

    • Place libffmpeg.so for Chromium 79 in the "lib_extra" folder. Got it from https://github.com/iteufel/nwjs-ffmpeg-prebuilt/releases/tag/0.43.6.

    • Copy "opt/google/chrome/WidevineCdm" to the "lib_extra" folder.

    • Edit "/usr/lib/x86_64-linux-gnu/opera/resources/ffmpeg_preload_config.json" to be:

      []
      
    • Edit "/usr/lib/x86_64-linux-gnu/opera/resources/widevine_config.json" to be:

        [
            {
               "preload": "/usr/lib/x86_64-linux-gnu/opera/lib_extra/WidevineCdm"
            }
      
        ]
      
    • Uninstall Chrome and delete "/usr/lib/chromium-browser" for good measure.

    In testing, unlike "lib_extra" for ffmpeg, Opera does not not search for the Widevine lib or the Widevine folder in any other place besides what's in widevine_config.json. It doesn't even search in "~/.config/opera/WidevineCdm".

    (See https://forums.opera.com/post/199264 (my reply/question to @jimunderscorep) for why I edited the config files so Opera only searches for its own copies of libffmpeg and widevine.)

  • Here's how I'm getting Widevine for Opera Stable without installing Chrome. It's based on https://gist.github.com/ruario/3c873d43eb20553d5014bd4d29fe37f1.

    wget https://dl.google.com/widevine-cdm/versions.txt
    
    wdm=$( cat versions.txt | tail -n1 )
    
    wget https://dl.google.com/widevine-cdm/$wdm-linux-x64.zip
    
    unzip $wdm-linux-x64.zip
    
    mkdir WidevineCdm
    
    mv manifest.json WidevineCdm
    
    mkdir "WidevineCdm/_platform_specific"
    
    mkdir "WidevineCdm/_platform_specific/linux_x64"
    
    mv libwidevinecdm.so "WidevineCdm/_platform_specific/linux_x64"
    

    Then, put the WidevineCdm folder in a spot Opera is looking for like /opt/google/chrome:

    sudo mkdir /opt
    
    sudo mkdir /opt/google
    
    sudo mkdir /opt/google/chrome
    
    sudo mv WidevineCdm /opt/google/chrome
    

    Then:

    cat /usr/lib/x86_64-linux-gnu/opera/resources/widevine_config.json
    

    and make sure the first preload is exactly:

    "preload" : "/opt/google/chrome/WidevineCdm"

    If not, fix it.

  • Hi guys, the Widevine is fixed now also in the latest Opera stable for Linux.

Log in to reply