Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Tabs not loading at startup

  • I'm not sure if I accidentally changed something recently, or if the latest versions of Opera Developer behave differently, but my tabs are no longer being loaded in the background. I've searched the Settings and Flags pages for "tabs", "background", and "delay"; but I didn't notice anything amiss. For example, my gmail tabs have the gmail icon on the tab as if they are loaded, but when I click on one, it will initiate a load of the page.

    How can I get Opera Developer to load all tabs at startup?

  • Note: I have "Delay loading of background tabs" turned off when experiencing the problem mentioned in my initial post of this thread.

  • I have the same problem. Tabs load only when I click on them instead of being loaded at Opera startup. I have some 30 tabs open and I would like them to open at startup.

    I also experience a problem when tab is loaded already. When scrolling down the content of the tab loads when showed on screen. Further I scroll down more of a content loads. I would like whole tab to be loaded when I open it. Not start loading after I scroll down. I don't know, maybe this is another issue but I just thought it's worth mention it.

  • I finally solved the issue: I first tried a clean install but used my previous profile. I still had the same problem, so then I started with a fresh profile and and had to "rebuild" my windows and tabs. But now when I start Opera my tabs are loading as expected.