Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Suddenly Opera No Longer Loads (Windows 10)

  • I had used Opera for quite a while and liked it a lot. But a few months ago I decided to switch back to Chrome.
    Lately I've been unhappy so today I decided to go back to Opera. But when I tried to open it all I get is a completely white window. No title bar or anything. I also had an older Beta version installed but it does the same thing.
    I rebooted, uninstalled, reinstalled and the same problem. Weirdly I can't seem to uninstall the Opera Beta. I go through the uninstall process but nothing happens.

    I tried creating a new Windows user account, and in that account the Opera Beta was already there and I also just get a white window. Nothing else.

    I do not know what has happened. I'd appreciate any help or ideas.

    Thank you.

  • First, for a test, download the Opera installer, launch it, click "options", set "install path" to a folder on your desktop, set "install for" to "standalone installation" and install.

    Does that Opera do the same thing? If so, it sounds like a graphics driver issue. You can go into the folder on the desktop, create a shortcut to launcher.exe, right-click the shortcut, goto "properties" and modify its command to pass --disable-gpu to it.

    "path to launcher.exe" --disable-gpu
    

    If it works then, it's a GPU issue.

  • For Opera Beta, you can delete:

    "C:\Program Files\Opera Beta"
    "C:\Users\yourusername\AppData\Local\Opera Software\Opera beta"
    "C:\Users\yourusername\AppData\Roaming\Opera Software\Opera beta"

    Then, when you try to uninstall Opera beta, Windows should ask you to remove the entry.

    You could do the same with regular Opera to if you want to make sure it's uninstalled and your profile is deleted before you reinstall.

    That should clear install issues up if Opera isn't uninstalling properly.

  • I've seen other messags like mine, but I haven't been able to solve this problem... I have a desktop Emachines computer, and I'm using Windows XP. Yesterday, I was using Facebook, and it was working fine. I was checking messages on one page, and playing the "Pirates" app in another window... and it all just stopped working. So I exited everything, and tried to sign back in, but when I did, the home page wouldn't load. It sort of comes up. It says Facebook, and it has the links at the top that say "profile, friends,inbox," and it has the little notification thing at the bottom... The little red bubble says I have 5 notifications, but when I click it nothing happens. I CAN however, click the "profile" link and go to my profile wall. I can see everything there, but none of the links work. I can't remove posts or anything.

  • @burnout426 I'm sorry about the delay. I never got reply notifications and I kind of forgot about this.
    I tried your first suggestion and that did nothing.
    Then I did the disable GPU trick and Opera opened fine. So this means it's a GPU issue, though I don't know what. I used Opera on this same computer in the past. It's old yes, but in my office we just can't justify new machines at this time.
    My GPU is an Intel G45/G43 Express Chipset. I've checked and there are no new drivers for it. So I don't know what to do. I would really like to start using Opera again.

  • @napman said in Suddenly Opera No Longer Loads (Windows 10):

    Then I did the disable GPU trick and Opera opened fine.

    Just for testing, try to see if just --disable-direct-composition or just --disable-accelerated-video-decode or just --ignore-gpu-blacklist or just --disable-gpu-sandbox works around the problem.

    Also, without any of the command-line options, goto the opera://gpu URL. It may reveal what the problem is with the GPU.

    So I don't know what to do.

    For now (after testing), you can modify Opera's shortcut so that its command is:

    "C:\Program Files\Opera\launcher.exe" --disable-gpu
  • @burnout426 said in Suddenly Opera No Longer Loads (Windows 10):
    --disable-direct-composition: opens to a completely white screen again.
    --disable-accelerated-video-decode: also just a white screen
    --ignore-gpu-blacklist: White screen
    --disable-gpu-sandbox: The same

    Since I can't get Opera to open properly at all without disabling the GPU I can't go to opera://gpu without using any of the command-line options

  • Since I can't get Opera to open properly at all without disabling the GPU I can't go to opera://gpu without using any of the command-line options

    Indeed. Silly me 🙂

    Ok on the command-line options not working. Guess you'll have to use --disable-gpu by modifying the shortcut.

  • Just for good measure:

    On the right side of https://blogs.opera.com/desktop/, you'll see some download links. Download the offline installers (64-bit if you have 64-bit windows) for stable, beta and developer. Launch each installer, click "options", set "install path" to a folder on your desktop, set "install for" to "standalone installation" and install. Use a different folder on your desktop for each of them.

    See if any of those make a difference.

    Test Vivaldi to see if it does the same. https://vivaldi.com/

    Test the latest Chromium builds: https://chromium.woolyss.com/download/en/

    Do they all fail or just Opera? Does Chrome still work?

  • @burnout426 said in Suddenly Opera No Longer Loads (Windows 10):

    Does Chrome still work?

    If so, test in Chrome Canary to make things still work. https://www.google.com/chrome/canary/

    Any difference in Brave? https://brave.com/download/

    They're all Chromium-based browsers, so it'd be good to know if it's just Opera or an issue in Chromium itself that maybe only Chrome works around.

  • @burnout426 What I've done is used the command-line to disable the GPU, then went into Opera settings and turned off hardware acceleration, then removed the command-line and Opera opened and seems to be working fine.
    Chrome does still work but it is slow.
    I'll give some of those other things a try later today.
    I really appreciate all your help.