Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Audio notifications in Win7 often don't work with Opera Mail.

  • I am perplexed. Sometimes audio notifications work and sometimes not. All other programs seem to activate audio notifications fine. With Opera Mail its intermittent. I have no idea what to check. I use the Win7 Volume Mixer at C:\Windows\System32\SndVol.exe to be able to adjust individual volume levels for each application. Very handy. Also it tells me if I'm going to get any notifications from Opera Mail. If its absent there ain't goin' to be any notifications for me! I haven't tried restarting Opera Mail at different intervals upon startup (would it help if it was the first thing started or could another program block these notifications from getting through to Win7?). Tis a mystery! Any suggestions would be most appreciated. I love Opera Mail. its relatively lean, very easy to use, very predictable but audio notifications are very important to my work and allow me to be much more untethered to the computer, as they are to most anyone using computers.

  • Close down Opera Mail and edit operaprefs.ini. See "Menu -> Help -> About Opera Mail" for the location. Under [User Prefs], make sure "Show Notification For New Messages" is NOT there so that Opera uses the default for the setting (which is 1). You can keep it there and set it to 1 if you want, but do the other way instead. Then, make sure you never mess with the checkbox in the settings UI as it's broken. It's really only broken for unchecking (trying to set it to 0), but just avoid the checkbox for good measure.

    That's probably not going to help as you already get notifications sometimes. But, I'd try it just for good measure so that you know the setting is right.

    Then, while Opera Mail is closed, for each account in question, check the section for the account in accounts.ini in the mail folder. You want Sound Enabled=1 set and Sound File=path to .wav file (make sure it's a .wav file).

    That's probably not going to help either as it sounds like things are set correctly.

    Then in the UI under the settings for each account, on the Incoming tab, make sure "Include this account when checking manually" is checked. Make sure "check every..." is checked and set it to less than 30 minutes (and no less than 10 if the server has a problem with you checking too frequently). You need to do that even if you're using IMAP and IDLE so the IDLE connection doesn't time out. You also need to make sure you're not using low-bandwidth mode.

    If everything's good and you still have the issue, you're out of luck. It just happens for some people in Opera Mail and no one has ever figured out why.