Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Settings not saved

  • In settings I choose „Allow sites to play flash”.

    Every time when I open Opera the settings have changed to ”Ask me first”.

    How can I solve this?

  • I remember this happening with the first update that brought the "Allow sites to run Flash" setting back. It worked, but got reset. I then deleted my Opera profile and it fixed it.

    Goto opera://about and take note of the profile folder. In it is a "Preferences" file. Close down Opera and edit it with JSONedit. In the root of the profile object in the Preferences file, you should have a default_content_settings_values object node. If it's not there, right-click on "profile", create the child node and name it that. Under the default_content_settings_values object should be plugins of type integer with a value of 1. If it's not there, add it. Save your changes and see if it sticks.

    You can open the file in JSONEdit while Opera is open and after you set "allow sites to run Flash" to see what it looks like. But, close Opera and open the file again before you edit it.

    Before you do any of the above though, disable all your extensions to see if one of them is overriding the setting.

  • Hello burnout426,

    Thank you very much for this explanation.

    Like many times before in my computer history, the following thing happens:

    -A small problem annoys me since many days.
    -In the end I post the problem on a computer forum.
    -And then the problem suddenly seems to have disappeared.

    So now I will wait if the problem comes back. I know what to do in that case.

    It’s strange but true.