Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Letters in Opera 53 aren't sharp

  • Hello I really like Opera Browser, use it on Android and Windows.
    Its fast and looks very nice, my only problem is that the font in Opera are grainy and blurry.

    To be clear, my Windows Desktop font is perfect also the font inside the websites.

    The problem is just visible on Opera (menu, settings, address bar...) how can i solve it?

    I use Windows 8.1 Pro 64
    Opera 53.0.2907.68

  • Have you look at Opera > Settings > Fonts?


    Windows 10 (x64) | Creators Update
    Opera Stable · Beta · Developer

    Opera Test profile | Opera Reset / Back up Linux · Mac · Win

  • I tried few fonts but still unsharp.
    I use the Dark theme

  • Has been looking fine at some point?

    Recent changes on Desktop's UI zoom?

    Assuming is an Opera UI (only) problem, look at Settings > Hardware Acceleration and toggle it to test.

    Other option would be to download the full Opera installer and reinstall on top.

    --
    You can also try the Test Profile from the signature's link, or try the portable installation option from the full Opera installer.


    If needed,
    search for Blurry fonts Chrome, they shares the engine, so look at there also.

    As well as VGA driver updates.


    Windows 10 (x64) | Creators Update
    Opera Stable · Beta · Developer

    Opera Test profile | Opera Reset / Back up Linux · Mac · Win

  • In case of DPI changes.

  • DPI settings are on Opera and Windows on default.

  • @victor27 ya might try this.. rigt click opera shortcut - Compatibilty tab - Check the box (Disable display scaling on high DPI settings) if no help leave unchecked

    Also check to see - right click start - Control Panel - Display - Adjust Clear Type Fonts.. make sure box is checked (Turn on clear type)
    0_1528878598388_0345b924-2cf8-4792-a068-8b1febb92865-image.png

    Also check to see - right click start - Control Panel - System - click on Advance system settings - Performace click the settings button - Visual Effects tab check the box (Smooth edges of screen fonts)
    0_1528878710363_403fce9b-94f1-43c7-9215-f486e81aefc4-image.png