Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Your connection was interrupted A network change was detected.

  • I use a PEPLINK 50 router that adds together three 10mbps internet lines from CenturyLink. Recently I've been getting this message in Opera 51

    Your connection was interrupted
    A network change was detected.

    Because of my PEPLINK router, as it switches back and forth between the three IPs, my IP changes, hence the network change notice. This does not happen in Edge and in previous 49 and previous versions of Opera. I would like to keep using Opera but I don't want to go into my router and tell it to use only one of my three internet connections (one IP that way)...since then I'd loose the speed advantage that led me to buy the 3 lines and the PEPLINK router in the first place. Is there someway of setting Opera so it isn't affected by changing IPs?

    So can someone help me with this so I can stay on my favorite browser, Opera? I am using the most recent version of Opera 51.

  • Solution 5 here might work. But, you're really having ip addresses change on you, so I don't know if the DNS workaround will work in your case. But, you can try it. You can use OpenDNS servers instead of Google's if you want. You can try setting them in Windows or at the router level. Again though, yours probably isn't an issue with DNS.

    Also, I'd search the net for Chrome/Chromium issues about this as you might have better luck.