Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Youtube does not work while logged in

  • This problem started a day or two ago.

    Steps to replicate :

    1. Login to youtube
    2. Click on a video to watch
    3. Video attempts to load but only thing on page is sidebars, etc. Address bar does show video link and if I refresh the page, the video will load. (sometimes requires multiple refreshes) From this point video will play, but if you click on any other video or even click on the youtube logo to try get back to the front page, nothing happens and the video just continues to play. (Note even hitting the back button does not stop video from playing, unless you hit back far enough to get off the youtube site)
      3.5. Opening a video in another tab/window does work, but still prevents you from clicking any links or opening another video in the same tab/window.
    4. Logout of youtube and do the same tests and everything works perfectly fine.

    On a side note, no comments load at all while signed in either.

    I have no extensions other than uBlock Origin and the in-built ad blocker installed, both of which are enabled in both cases, so it's not them causing any problems.

    I have cleared browser cache/history/cookies, etc. Have updated to latest version and nothing fixes the problem. No changes have been made to my config and no new software has been installed on my pc in the last week or so.

    Note this is not an issue in other browers as I have tried in Chrome/IE/Safari and I do not have this issue.

    Problem occurs in Opera for Mac as well.

    Anyone got any ideas. This may finally break me and cause me to leave Opera for another browser.

  • @vaughanb I have the same problem sice 3 hours. I discoverd that you make a search, then click in click bar and press enter, then make other search and will work fine for this sesion.

  • Reinstall the opera (download a new version on the site), I had the same problem and when reinstalling it was solved