Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Can't install Opera 51 on Ubuntu 14.04 LTS

  • @ygbourhis
    Well, things don't appear to be looking too good.

    First, I downloaded Opera's deb package for 52.0.2871.37, then applied your procedure to patch the package using these commands as root:

    dpkg-deb -R opera-stable_52.0.2871.37_amd64.deb opera-stable_52
    sed -i s/'libdbus-1-3 (>= 1.9.14)'/'libdbus-1-3 (>= 1.6.18)'/ opera-stable_52/DEBIAN/control
    dpkg-deb -b opera-stable_52 opera-stable_52_trusty.0.2871.37_amd64.deb
    dpkg -i opera-stable_52_trusty.0.2871.37_amd64.deb

    The package installed without any error indications, but when I tried to run the executable, Opera's start screen flashed for about a second, then reappeared with a message saying opera was recovering from a crash. This sequence repeated three more times before it ended. Here's the first two of six lines of what's in syslog:

    Mar 29 14:43:43 Pentium90 kernel: [344076.864647] opera[13671]: segfault at 148 ip 000000000380ffa9 sp 00007fff9304b570 error 4 in opera[1a1e000+5afc000]
    Mar 29 14:43:51 Pentium90 kernel: [344085.252247] opera[13910]: segfault at 148 ip 000000000380ffa9 sp 00007fff06c26fa0 error 4 in opera[1a1e000+5afc000]

    Perhaps there's a pilot error here in trying to apply a patch for one version of the package against a later version?

    Next, I tried downloading your patched package 52_trusty.0.2871.30 using wget with "-c --tries=0" options per your suggestion. This completed - apparently successfully - after about six hours and 26 tries at an average speed of 4-6 KB/s. However, when I tried to install, theinstallation failed. Here's the console interaction.

    -su(root)# dpkg -i opera-stable_52_trusty.0.2871.30_amd64.deb
    (Reading database ... 214731 files and directories currently installed.)
    Preparing to unpack opera-stable_52_trusty.0.2871.30_amd64.deb ...
    Unpacking opera-stable (52.0.2871.30) over (50.0.2762.67) ...
    dpkg-deb (subprocess): decompressing archive member: lzma error: compressed data is corrupt
    dpkg-deb: error: subprocess <decompress> returned error exit status 2
    dpkg: error processing archive opera-stable_52_trusty.0.2871.30_amd64.deb (--install):
    cannot copy extracted data for './usr/lib/x86_64-linux-gnu/opera/icudtl.dat' to '/usr/lib/x86_64-linux-gnu/opera> /icudtl.dat.dpkg-new': unexpected end of file or stream
    Processing triggers for menu (2.1.47) ...
    Errors were encountered while processing:

    I suspect that here there may really be an undetected or unnoticed wget error based on the long wall clock time and slow communication rate.

    Looks like it may be a little early to conclude that opera works OK with the down-revved libdbus-1-3 dependency. Interested in hearing your comments.


  • @bbatten
    Color me embarrassed. I neglected to follow "dpkg -i ..." at the end of the package modification attempt described above with "ldconfig".
    Now working fine.

  • It Works !!!
    Thank you very much!!!

  • @bbatten So modifying by hand works for you also?
    If so, this is good news and I hope opera will consider repackaging with proper requirements.

  • New version 52.0.2871.40 is out, so:

    dpkg-deb -R opera-stable_52.0.2871.40_amd64.deb opera-stable_52
    sed -i s/'libdbus-1-3 (>= 1.9.14)'/'libdbus-1-3 (>= 1.6.18)'/ opera-stable_52/DEBIAN/control # change the requirement
    dpkg-deb -b opera-stable_52 opera-stable_52_trusty.0.2871.40_amd64.deb

    available here

    Opera Guys: we've proven it works with libdbus-1-3 (>= 1.6.18). So could you just do a proper packaging job?

    Thanks in advance.

  • @ygbourhis I don't think they will change the minimum requirements to install Opera.

  • Hi @leocg Is there no chance that they change their decision to support 14.04 till EOS?
    All those here who tried my solution did the free QA for Opera guys and proved irrelevant to not support 14.04
    We did the effort to validate that it works on 14.04 Could we not expect a least effort now from Opera?
    The change is just so trivial.

  • @ygbourhis If they decided to set Ubuntu 16.04 as the minimum version to install Opera on that system, it's because they have good reasons for doing it.

  • @ygbourhis
    I downloaded the deb file for 52.0.2871.40 from Opera's download site and applied your package patch Fri 3/30/18. I've been using it regularly since then and everything seems to be working right except for the No-Script Suite Lite extension.

    Opera crashes every time I click on the script's gear icon unless I'm in Opera's settings tab. Opera 52.0.2871.40 installed on Ubuntu 16.04 does not have that problem.

    I'm digging a little deeper to see if I can get some idea of what's going on, but in my view it may be a little early to claim absolutely everything works. I'll post what - if anything - I find out here.

  • @ygbourhis Duh. It just now dawned on my that you are using Ubuntu 14.04. Can you click on the No-Script Lite gear icon from any web page (not just the settings tab) without getting a crash?

    If so, I think that would remove the qualm I have about the down-revved libdbus-1-3 requirement. I use my Devuan system as a development box, so its configuration may not be entirely cruft free. After all, as you say, the change is very trivial.

    Thanks again for the package patch.

  • @bbatten Are you using a plugin? because I do not have this Icon.
    With Opera 52 repackaged for trusty even the following issue is fixed:
    While if I stay with the last opera 14.04 compatible I can't access my bookmarks without a crash.
    Have you tried with a new opera profile? Maybe you have some incompatible plugin.

  • @ygbourhis For me, Noscript Lite shows up under "about:extensions". Clicking Enable will make it show up as a little shield at the very right end of the address bar. Clicking on the little shield causes a small window to appear with a box labeled '+' and a box containing a gear symbol. I've found that clicking on the gear symbol results in a crash when I'm on a web page. The only place I've found that there is no crash is when I'm on the settings tab.

    The crash does not happen when I'm running the same version of Opera on Ubuntu 16.04.

  • @bbatten Ok, so it's an add on. Did you try deinstalling and then reinstalling the noscript addon?
    I added it :
    And have no issue with Opera 52 on Linux Mint Qiana (Based on Ubuntu Trusty).

  • @ygbourhis No. So I deinstalled it, then downloaded from its website and activated it. Same results. Opera crashes if I click the gear icon in anything other than the Settings tab. Here's syslog:

    [1] bryan: grep opera /var/log/syslog
    Apr 10 12:50:30 Pentium90 kernel: [613766.044865] opera[16412]: segfault at a8 ip 0000000004f4fe65 sp 00007ffc00147540 error 4 in opera[1a1e000+5afe000]

    Looks like there's a good probability that I have cruft in my environment (it's used for development after all). Be nice if someone could test in exactly Ubuntu 14.04.

  • I removed the old packages and instead made a script to automaticaly create a backported opera version for trusty.

    Here it is:
    Or here:

    Once downloaded make it executable:

    chmod a+x

    And simply launch this command in the directory where you downloaded opera:

    ./ opera-stable_52.0.2871.64_amd64.deb

    (Replace opera-stable_52.0.2871.64_amd64.deb with the newly downloaded version)

    You can find the source code here:

    Hope this helps.

  • How to Installl GDebi on your Linux machine:

    1. Open a Terminal and tap this command:
      sudo apt-get install gdebi
    2. Go to:
      and download the Opera-WebBrowser for Linux:
    3. Go to your Downloads directory an double klick on:
    4. It will install Opera like a Setup.exe on a Windows Computer.
  • sudo dpkg -i <package_name> works just fine.

  • @night-owl-cat + @fredyavatar
    Thank you for your contributions to the subject, but if you have read the first... 5 answers of the thread, you would see the WHY opera 51+ can not be installed on ubuntu 14.04 and similarly old distros and you would not post the HOW.

  • @ygbourhis: Thank you so much for this workaround, it seems to be working fine! 🙂

    I was just about to consider upgrading my system to the new LTS, but I'm not sure now, since keep using Opera would've been my only real reason, but that seems to be sorted now, as long as this script works (not sure if it will work with 60.x versions later, but I don't see why it shouldn't).

    Finally with the new version I could get rid of the annoying Ctrl+Tab crash bug! 🙂

  • @metaltrabant You're welcome.
    The only issue with my script is that we need to manually check for opera updates. But indeed it allows postponing the LTS upgrade.

Log in to reply