Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Can't install Opera 51 on Ubuntu 14.04 LTS

  • I don't get you. Can you be more specific, please?

    All the complaints made in this thread here start from one small change on the version of a lib that opera depends on. I think I nave analysed the "why" behind that change as much as possible on my posts above.
    Opera 52 depends on the exact same version of libdbus that opera 51 was and that alone is what makes it impossible to install on old distros, so nothing has changed to all I say except for opera's (and chromium's) version number.

  • @jimunderscorep As far as I know, they fixed that issue but the fact that you need at least Ubuntu 16.04 didn't change.

  • There are a lot of browsers in the market. Should Opera insist only supporting Ubuntu 16.04 starting from Opera 51, the only choice we users can do is to stay with Opera 50 or stop using Opera. I don't think Opera team will give in based on the small user base of Ubuntu 14.04.

  • @huwanhsin
    There are obviously many other browsers out there for someone looking a substitute for opera on an old distro, but

    How many of them are built with a good browser engine like firefox's gecko or chrome's blink and not some webkit fork for qt/gtk? A good browser engine is the key feature that provides decent performance to today's web pages whose complexity is increasing every year.

    How many of them draw their ui with a good toolkit like gtk or qt and not with today's really famous crap, electron, like vivaldi, min and brave do? For me, this is a major issue, because I refuse to use an app that uses a huge amount of libs and an engine ONLY to draw its ui and nothing more. The reason behind that is usually a lazy dev that does not bother to build the application's ui with a nice toolkit.

    If you are disappointed by opera's decision to move forward and drop support for distros that use an older version of some lib, you are free to use chrome which depends on an even older version of libdbus than opera 50 used to. Keep in mind however that asking for support on an 4-year old distro is pretty much the same as asking for support for an os like vista, which is neither supported by chrome or firefox right now.

    Kinda offtopic, but since qt4 was mentioned on this thread, ubuntu drops support for qt4 completely for the next year's release

  • @leocg I think the reason for opera's ubuntu 16.04 requirement is that it has version 1.10.6 of libdbus-1-3. Again, if the set of functions in that library that opera actually uses hasn't changed, then it seems that the version dependency could be safely left down rev. That would have the advantage of increasing the target population of installable systems, which I think opera would have in interest in maximizing.

  • Opera 51 was released like ~1.5 months ago. If the there was someone really, REALLY interested to make it install and test it on 14.04, he would change the control file so as to list libdbus 1.2.x (or whatever opera 50 had) as dependency and install it.

    But no. This thread has 30+ comments (and 4500+ views) at the time I am writing this. Most them are either mine explaining the obvious "why linux sucks as a desktop os" situation or others complaining with "but this browser does install" examples. Why? Because complaining is easier than admitting something. I even got a downvote from someone who can not accept how things are,

  • Well, I guess I'm really talking for the benefit of opera as a business. A quick look at Distrowatch shows that Mint, Manjaro, and Debian all are downloaded more than Ubuntu. In addition there are many other deb based distributions (my own is Devuan Jessie) that would seem to argue for anyone distributing on a Linux based platform to be interested in supporting.
    So the takeaway is that downrevved dependencies help maximize the potential market. Hopefully the fine folks at Opera will incorporate that observation in evaluating dependency policy going forward.

    ... just one man's opinion, folks.

  • @jimunderscorep

    I'm just replying from Opera 52 under Linux mint Qiana (Ubuntu Trusty)

    To do this I did the following:

    dpkg-deb -R opera-stable_52.0.2871.30_amd64.deb opera-stable_52
    vim opera-stable_52/DEBIAN/control # Change to "libdbus-1-3 (>= 1.6.18)" and save
    dpkg-deb -b opera-stable_52 opera-stable_52_trusty.0.2871.30_amd64.deb

    The repackaged file is here:

    So now I confirm it works with "libdbus-1-3 (>= 1.6.18)" so could Opera devs learn how to package things as I mentionned before?

    Hope this helps.

  • @ygbourhis
    Thanks for making the patched deb package available. Unfortunately, wget fails with this message:

    • Read error at byte 43323441/55094366 (The TLS connection was non-properly terminated.). Giving up.

    In the meantime, over at Debian Repository Unofficial, you can follow the link to Google Chrome to download Chrome 65. Installing the deb package also creates an entry under /etc/apt/sources.list.d so that subsequent updates to chrome are enabled. Chrome 65 works fine under Devuan Jessie, and it is fast.

  • @ygbourhis
    your method works! thank you!

  • @bbatten strange, have you tried with curl or with a browser?

    curl _o opera-stable_52_trusty.0.2871.30_amd64.deb

  • Sorry, replace _o by -o before the file name in the curl command

  • @bbatten Maybe you have a network issue, for me both wget and curl work:

    yves@paradox ~ $ wget

    --2018-03-28 10:51:25--
    Résolution de (…
    Connexion à (||:443… connecté.
    requête HTTP transmise, en attente de la réponse… 200 OK
    Taille : 55094366 (53M) [application/x-debian-package]
    Enregistre : «opera-stable_52_trusty.0.2871.30_amd64.deb»

    100%[============================================================================================================================================================>] 55 094 366 2,99MB/s ds 23s

    2018-03-28 10:51:48 (2,33 MB/s) - «opera-stable_52_trusty.0.2871.30_amd64.deb» enregistré [55094366/55094366]

    yves@paradox ~ $ curl -o opera-stable_52_trusty.0.2871.30_amd64.deb

    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 52.5M 100 52.5M 0 0 2767k 0 0:00:19 0:00:19 --:--:-- 2454k

    Have you tried with curl or with a browser?

  • @ygbourhis
    If it's a network issue, it's a weird one; I have all the network functionality I need to login and reply to your post. Maybe path speed is too slow (see end of post)? Anyway, I tried the download twice yesterday using Firefox, then once more using wget, failing with each.

    Earlier this morning I pasted your wget command line into a terminal window, and that failed:
    2018-03-28 12:07:09 (10.1 KB/s) - Read error at byte 44443264/55094366 (The TLS connection was non-properly terminated.). Giving up.

    Then I pasted your curl command line into a terminal window and that failed too:

    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    3 52.5M 3 1859k 0 0 10726 0 1:25:36 0:02:57 1:22:39 13177curl: (18) transfer closed with 53186694 bytes remaining to read

    Maybe the line speed is too slow (@10-14 KB/sec)?

    So anyway, right now, I'm trying an experiment using wget in which I simply repeat the command after each failure termination on the assumption that it will just pick up where it left off the last time --- aka "Hail Mary"!

    I'll post results.

  • @bbatten It lloks indeed like a bandwith issue and the connection is closed before the end of download.

    Simply modify the original deb if you can get it from opera and then in the download directory of the original fil you can copy paste what follows in a terminal:

    sudo apt-get install fakeroot # (If fakeroot is not installed)
    fakeroot # this simulates a root environment to preserve file permissions
    dpkg-deb -R opera-stable_52.0.2871.30_amd64.deb opera-stable_52 # unpackage the original
    sed -i s/'libdbus-1-3 (>= 1.9.14)'/'libdbus-1-3 (>= 1.6.18)'/ opera-stable_52/DEBIAN/control # change the requirement
    dpkg-deb -b opera-stable_52 opera-stable_52_trusty.0.2871.30_amd64.deb # rebuild a new package
    exit # exit fakeroot environment

    You can batch copy/pase all the lines above (with the comments) in a terminal.
    <crtl-c> the whole lines above and <caps-ctrl-v> in a gnome/mate/etc... terminal (I tested them).
    And you will end up having the same pakckage as I uploaded.
    Do not worry if the second last line (before the "exit" command) takes some time, it's normal.

  • @bbatten

    Could you please give me your time zone?
    I will check at your 12:07:09 time (per your log above) in my server logs to see if we have errors to know why you can't download, but I need to know your time zone to convert your 12:07:09 local time to UTC in order to see our server logs at that moment when you had the issue.

    Just to check If I have server errors to know if the fact you can't download is from my side or your side

    Thanks in advance.

  • @ygbourhis
    Thanks for your help. My timezone is PDT (California). I'm in the process of trying to download the package again right now (averaging @ 8-9 KB/s).

    California is a long way from France. Maybe the weight of ship traffic passing overhead is squeezing the cable enough to constrict data flow?

    Thanks again,

  • @bbatten Ok, I will check if we have error logs at that time.

    However, we managed to reproduce the issue by simulating a 10KB/s download (with 'trickle' : ).
    We are trying to fix this but have no idea how long it will take, so thanks for noticing this, I logged a BUG issue concerning our servers 🙂

    Try the --continue and --tries parameters with wget. Or did you try modifying the opera original package with the commands I gave above?

    I hope that the Opera guys will note that their browser works well with trusty and that they'll reconsider packaging it properly (If they are a minimum serious they should, I think that we did the QA for them with the modified package).

    The more we confirm that Opera 52 works on Trusty the more chance they will consider "not losing users" and think repackaging. Especially knowing that Trusty is still supported for one more year.

  • @ygbourhis
    Well, things don't appear to be looking too good.

    First, I downloaded Opera's deb package for 52.0.2871.37, then applied your procedure to patch the package using these commands as root:

    dpkg-deb -R opera-stable_52.0.2871.37_amd64.deb opera-stable_52
    sed -i s/'libdbus-1-3 (>= 1.9.14)'/'libdbus-1-3 (>= 1.6.18)'/ opera-stable_52/DEBIAN/control
    dpkg-deb -b opera-stable_52 opera-stable_52_trusty.0.2871.37_amd64.deb
    dpkg -i opera-stable_52_trusty.0.2871.37_amd64.deb

    The package installed without any error indications, but when I tried to run the executable, Opera's start screen flashed for about a second, then reappeared with a message saying opera was recovering from a crash. This sequence repeated three more times before it ended. Here's the first two of six lines of what's in syslog:

    Mar 29 14:43:43 Pentium90 kernel: [344076.864647] opera[13671]: segfault at 148 ip 000000000380ffa9 sp 00007fff9304b570 error 4 in opera[1a1e000+5afc000]
    Mar 29 14:43:51 Pentium90 kernel: [344085.252247] opera[13910]: segfault at 148 ip 000000000380ffa9 sp 00007fff06c26fa0 error 4 in opera[1a1e000+5afc000]

    Perhaps there's a pilot error here in trying to apply a patch for one version of the package against a later version?

    Next, I tried downloading your patched package 52_trusty.0.2871.30 using wget with "-c --tries=0" options per your suggestion. This completed - apparently successfully - after about six hours and 26 tries at an average speed of 4-6 KB/s. However, when I tried to install, theinstallation failed. Here's the console interaction.

    -su(root)# dpkg -i opera-stable_52_trusty.0.2871.30_amd64.deb
    (Reading database ... 214731 files and directories currently installed.)
    Preparing to unpack opera-stable_52_trusty.0.2871.30_amd64.deb ...
    Unpacking opera-stable (52.0.2871.30) over (50.0.2762.67) ...
    dpkg-deb (subprocess): decompressing archive member: lzma error: compressed data is corrupt
    dpkg-deb: error: subprocess <decompress> returned error exit status 2
    dpkg: error processing archive opera-stable_52_trusty.0.2871.30_amd64.deb (--install):
    cannot copy extracted data for './usr/lib/x86_64-linux-gnu/opera/icudtl.dat' to '/usr/lib/x86_64-linux-gnu/opera> /icudtl.dat.dpkg-new': unexpected end of file or stream
    Processing triggers for menu (2.1.47) ...
    Errors were encountered while processing:

    I suspect that here there may really be an undetected or unnoticed wget error based on the long wall clock time and slow communication rate.

    Looks like it may be a little early to conclude that opera works OK with the down-revved libdbus-1-3 dependency. Interested in hearing your comments.


  • @bbatten
    Color me embarrassed. I neglected to follow "dpkg -i ..." at the end of the package modification attempt described above with "ldconfig".
    Now working fine.