Animated gifs not working in Twitter/Facebook

  • I had this working with Linux Mint 18.3
    Could it be a new update that I installed yesterday - package file is chromium-codecs-ffmpeg-extra_64.0.3282.119-0ubuntu0.16.04.1_amd64.deb? (There was a new version of Chromium as well.)
    I am using Opera version 50.0.2762.67.

  • It seems that what I predicted here is true
    https://forums.opera.com/topic/23908/just-about-all-videos-won-t-play/35

    Opera 50 is chromium 63 based, your chromium ffmpeg codecs are chromium 64 based, so you get the idea.

  • @jimunderscorep I see. Will be good if Opera can come up with a proper fix for this. Maybe it's not a good idea for them to rely on a Chromium package that could be a different version. Build a separate Opera version of the same package in case they are different versions? Which might mean having two similar packages but would at least be a solution to stop this happening every so often. It does seem to come up quite a lot.

  • Opera does not really depend on that package. It has its own libffmpeg, but it only supports a very few and loyalty-free formats, eg webm, ogg etc.
    The problem is that most sites use mp4, h264, mp3 etc in their html5 based pages, so opera does not work properly there.

    The solution is to "enhance" opera with chromium's libffmpeg and that really is the solution that we all suggest for distros that do package chromium ffmpeg extras (e.g ubuntu and derivatives). This solution, lately, seems incomplete because opera needs chromium's libffmpeg it was built on. Opera 49 was built on chromium 62, opera 50 was built on chromium 50 and so on.
    Other distros, like debian and mandriva, do not package chromium codecs and users of those distros have no solution to that problem.

    On top of that, there is the time difference between chromium (from upstream) and opera are released. Chromium 63 was released on early December 2017, while opera 50 was released on early January 2018. This left opera users with broken html5 support for 1 month! And after ~15 days from opera's release date, chromium 64 was released from upstream, so things broke again.

    Imho, opera MUST follow a tighter release schedule so as to be in better sync with chromium releases. Besides, they also have opera-beta and opera-developer branches, so moving opera-beta to the stable channel earlier should not be a big issue.
    Else, the "poor html5 support" problem (lets give it a name) will live on.

  • Hi,

    This will be fixed as soon as Opera releases its next stable release.

    But until that time, you can downgrade by installing http://launchpadlibrarian.net/345863538/chromium-codecs-ffmpeg-extra_62.0.3202.94-0ubuntu0.16.04.1317_amd64.deb to have it work with the current Opera version.

  • @avl Unfortunately I had to migrate back to Chrome. I was too bored with Opera's not playing simple mp3 file (https://goo.gl/Nt1qSg) animated GIF's in Twitter... Instead of improving the browser Opera's team is making regres. 😞

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.