Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Screen Blinking/Flashing while opening YouTube videos.

  • Hi, I bought a new monitor today, I connected it with a standard HDMI cable that came with it.
    I have a dual monitor setup, the second one is connected with a DisplayPort to HDMI cable, as my GTX 960 only has one HDMI, one DisplayPort and 2 DVI's.

    This only happens on my new monitor, the one connected with HDMI to HDMI, previously I was using the same installation, the same cable but with my old monitor and this wasn't happening.

    Disabling Hardware Acceleration helped but I notice the browser really slow.

    My question is, why does it happens only on my main monitor? If the problem was the monitor, then why disabling Hardware Acceleration solves the issue?

    I have to say that this doesn't happens every time I open a youtube video, only some times, I tested playing a game and it doesn't blink.

    SPECS:

    • Intel i5 4670K @3.4GHz
    • 16GB DDR3 RAM
    • 128GB SSD only for the system and essential programs such as Opera, IntellIJ...
    • 1TB 7200rpm HDD
    • NVidia GeForce GTX 960 4GB
    • 2 1080p monitors at 60Hz

     
    Thanks for the help.

  • Hi,

    I also experience this issue. It is not only videos flashing, but also contents of tab A in window 1 will show up in Tab B of window 2. Sometime very short, sometime a couple of seconds.
    When i switch over to VGA cable no issue exists.

    Did you perhaps find a solution yourself?

  • @thel0w3r and @KrisNL

    dunno if this will help.. Open the Nvidia Control Panel and in the global nvidia settings's choose vsync and turn it on.. and or connect through display port (DVI).. try another slot if possible..

    Get the latest driver for your card.. ummm.. no overclocking card lol

    Try different cables too if ya can. Make sure all cables in system are seated well etc too.. sum cables do 1440p only.. but not in your case.. *just say 'n..

    dunno what monitor ya use but Asus monitors do not go good with that card..

    Ummm.. if intell graphic is diabled then the rest of this does not matter..

    Your PC will have integrated graphics and may be defaulting to them even if you have a powerful graphics card installed.

    Inside, your laptop or PC will be a processor (or CPU) and this will probably have its own graphics capabilities – commonly known as integrated graphics because it's baked onto the chip. It means your computer can run a display without any help but for more demanding tasking like gaming a dedicated graphics card is more appropriate.

    Most PCs and some laptops will have a dedicated graphics card and means that there's a choice of which to use. By default your computer should pick the integrated graphics for lighter tasks to save power and automatically switch to the full-blown GPU when needed.

    Most PCs and some laptops will have a dedicated graphics card and means that there's a choice of which to use. By default your computer should pick the integrated graphics for lighter tasks to save power and automatically switch to the full-blown GPU when needed.

    Whether you don't agree with the automatic switching or think it's malfunctioning, you can take control of what happens by setting a default graphics card.

    1. Open the Nvidia Control Panel (eg. by right-clicking on the desktop)

    2. Go to “Manage 3D settings” and select the “Program settings” tab

    3. Select the application that has flickering issues in the dropdown menu

    4. Choose “High performance NVIDIA processor” as the preferred graphics processor

    After saving the settings, remember to completely close and restart the application for which you just changed the settings. When you relaunch the application, all screen flickering should now be gone!

    Note - If it is still in some auto selection mode, since it continues to flicker? Otherwise, you may have other applications running at the same time, which runs on the integrated graphics? If possible, you could try and disable the internal graphics completely, to force all applications to run on the Nvidia card, and then reboot. This would reduce battery time, but might make the flickering problem go away…
    Not sure exactly where to do this, though. Best of luck in your troubleshooting..

  • You can adjust this while the computer is on, go into a full screen application where the issue occurs, and move jiggle the card around or bridge on the pins until it stops doing it... lol

    disabled physx (changed to cpu) in nvidias control panel if ya got that..

    i read this in a thread earlier for gtx 970 card..

    I have an MSI GTX 970 Gaming 4G, i5 4590, Windows 8.1 x64, etc, etc... and I was having the screen flickering/blacking out issue. As I continued to look deeper into the problem, I came across the release notes for the latest driver (353.30). Here is a link to the pdf:

    http://us.download.nvidia.com/Windows/353.30/353.30-win8-win7-winvista-desktop-release-notes.pdf

    On page 23 it talks about a screen flickering issue with Windows 8, specifically. It states that the fix is:
    1 Reboot in Safe Mode.
    2 Uninstall the driver.
    3 Disconnect from the internet and then restart the system.
    4 In normal mode, install the new driver.

    It says the reason is because of a conflict with an old driver (if you've upgraded recently to the newest one). However, there are some nvidia components you won't be able to uninstall in safe mode. I found the best way is to just turn off the internet and uninstall everything from normal mode. Once you're done and rebooted, just make sure (in device manager) that it's not using anymore nvidia drivers for the GPU and it will be some generic microsoft driver. Then go ahead and install the latest one, 353.30, from here (MAKE SURE you download before disconnecting from the internet, obviously):

    http://www.geforce.com/drivers/results/86504 (This one is for the GTX 970. You'll have to find your own if it's a different type, but just make sure you download the 353.30 one)

    So far I haven't had any issues since I've done this. I'll report back on this page if anything changes, but this should be a solid fix for those experiencing this issue with Windows 8 or 8.1.

  • Hi @nvmjustagirl

    i played around with some settings.
    What is did:

    • install opera 64bit. (it's not that easy to find on Opera site)
    • set opera to use Nvidia card

    This already decreased the problem.

    Then, I disabled my (only) plugin:
    'Ublock Origin' >> instantly the flickering and content mixing between Opera windows is gone, NICE!
    Next, I tried disabling the build-in spam blocker to check if these two were conflicting with each other. but that was not the case.

    Will do some testing later, as my current (second) monitor setup will not exhibit this odd behavior.