Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera not working with VPN. Only works with Opera Turbo enabled

  • This post is deleted!
  • I recently downloaded Opera as several sites I use require me to turn off my adblocker and when I do, still show that it's turned on (even after uninstalling the ad blocker as well as uninstalling and reinstalling browsers) but that's another issue. So I started using Opera. Up until several days ago, it worked great. Then out of nowhere (with no changes) when I opened the browser, nothing would load. It just had the spinning loading circle. I couldn't even get the help page to open. After uninstalling and reinstalling the browser it was fine but then it did it again. So I uninstalled and reinstalled it AGAIN. This time, I went through all the settings looking for anything changed but there was nothing. Then I saw "Opera Turbo" and enabled it. Then all of the sudden, the browser works fine. So I'm wondering why it won't work with the VPN (either on or off) and only works with "Opera Turbo" enabled and why it started randomly when the VPN worked fine before.
    0_1515457732731_Opera browser.jpg

  • @xolindsayox

    You can try installing Anti-Adblock Killer on Opera's AdBlocker settings.

  • @zalex108 Thanks but that issue (adblocker being disabled and sites saying it's not) is only an issue on other browsers which is why I needed another one to use. That being Opera but thanks for the tip!

  • @xolindsayox if i may ask what version of opera did ya install..

  • @xolindsayox
    All vesions of opera below 49.0.2725.64 with VPN/On opera killed the vpn.. also the older version did not require Port 8000

    The newer Opera's 49.0.2725.64 version And on up with Vpn/ON Are the only Ones that have opera's VPN currently Working..

    Note all newer version require Port 8000 outbound to be open..

    and since ya said you looked and nothing has changed then maybe firewall or anti-anything could be blocking port 8000..

    if you installed opera 49.0.2725.47 or older vpn has been killed but turbo does still work.. i think lol

    *just saying..

Log in to reply

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.