Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera stopped being able to even launch

  • I've been using Opera on my Mac for the last six months or so without any issues.

    However, last Saturday (Dec 30, 2017), it crashed and won't launch again.

    I've tried uninstalling and re-installing, without any success.

    I went to the FTP site and tried installing an older version of Opera (ver. 49.0.2725.34) that works fine. However, it kicks off the auto-updater and automatically updates, and then won't launch again.

    Any help in troubleshooting is much appreciated!

    Process:               Opera [3019]
    Path:                  /Applications/
    Identifier:            com.operasoftware.Opera
    Version:               49.0 (49.0.2725.64)
    Code Type:             X86-64 (Native)
    Parent Process:        ??? [1]
    Responsible:           Opera [3019]
    User ID:               501
    Date/Time:             2017-12-31 00:47:24.905 -0600
    OS Version:            Mac OS X 10.13.2 (17C88)
    Report Version:        12
    Bridge OS Version:     3.0 (14Y661)
    Anonymous UUID:        915EE9E3-5984-8E4A-6CEA-D7B1EC812BE9
    Time Awake Since Boot: 880 seconds
    System Integrity Protection: enabled
    Crashed Thread:        0  Dispatch queue:
    Exception Type:        EXC_CRASH (SIGABRT)
    Exception Codes:       0x0000000000000000, 0x0000000000000000
    Exception Note:        EXC_CORPSE_NOTIFY
    Application Specific Information:
    abort() called
    Thread 0 Crashed:: Dispatch queue:
    0   libsystem_kernel.dylib        	0x00007fff757ece3e __pthread_kill + 10
    1   libsystem_pthread.dylib       	0x00007fff7592b150 pthread_kill + 333
    2   libsystem_c.dylib             	0x00007fff75749312 abort + 127
    3   com.operasoftware.Opera       	0x0000000108a59d85 0x108a59000 + 3461
    4   libdyld.dylib                 	0x00007fff7569d115 start + 1
    Thread 0 crashed with X86 Thread State (64-bit):
      rax: 0x0000000000000000  rbx: 0x00007fffae7b4340  rcx: 0x00007ffee71a6b38  rdx: 0x0000000000000000
      rdi: 0x0000000000000307  rsi: 0x0000000000000006  rbp: 0x00007ffee71a6b70  rsp: 0x00007ffee71a6b38
       r8: 0x00007fffae794048   r9: 0x0000000000000040  r10: 0x0000000000000000  r11: 0x0000000000000206
      r12: 0x0000000000000307  r13: 0x00006040000cc080  r14: 0x0000000000000006  r15: 0x000000000000002d
      rip: 0x00007fff757ece3e  rfl: 0x0000000000000206  cr2: 0x00007fffae792148
    Logical CPU:     0
    Error Code:      0x02000148
    Trap Number:     133
  • Ruining this command from Terminal blocks the AutoUpdate.

    • defaults write com.operasoftware.Opera OPDisableAutoUpdate true

    About why the latest update broke the start up, I don't know.

    You should try with a clean install or wait for the next update (despite that it's not assuring to fix the problem.)

    For the clean profile, look at here.

    Windows 10 (x64) | Anniversary Update
    Opera Stable · Beta · Developer

    Opera Test profile | Opera Back up Linux · Mac · Win